View Full Version : A problem with http request to a webobjects site

04-18-2012, 06:58 AM
Hi! There's a site on WebObjects with a registration and authorization. I write a code that will register automatically on that site(a code on another server, on my site). I want to realize this with a HTTP POST request (language PHP).
On that WO-site everything is simple:
- Main page with an authorization form. (Link to register-form page below)
on start this page send back http-header asking "browser" to set these cookie:
1. wosid=4Q2VQfhC5r2Dcu27brmZH0;
2. woinst=-1;
3. JSESSIONID=6DE82EE80322335D4582FFE33C8F7128;
Then i press a link "register" and go to a register-form page.
my browser sends back those cookie: wosid, woinst and JSESSIONID.
I fill in a form. Press "Register" submit button. Page reloads and says me that i've just registered.
That's all.

A wrote a php code that sends a http GET request to the main page of that WO-site to get those cookie(wosid, woinst and JSESSIONID)
A save cookie and send it to a WO-site server, but in the http POST request and with required post data (to the url that pointed in "action" attribute of the form on the register-form page)

I expect that server will return me some "success page" but it returns
"You backtracked too far.
The application backtracking limit of 30 has been exceeded."

What does it mean?

I think, I've already tried everything.. but still no success.

Can anyone help me with this? =) Any suggestion?