View Full Version : can't access or see windows partition!

04-08-2011, 01:04 PM
Hey guys,
this is my first post, so hopefully i landed in the right sub forum :)
Yesterday I decided to clean my Macbook Pro after 2 years of use. Basically what I had was 1 Mac Partition (~370 GB), 1 Windows Partition (~110 GB) and 1 Linux Partition (~20 GB). What I did was formatting the Mac and Windows Partition, while I left the partitions in tact like they were before. The Linux Partition was left untouched.
I then Installed Mac OS 10.6 and after that I installed Windows on the 110 GB Partition, but without using bootcamp from inside of Mac OS... I guess that caused some trouble. Because I have no way of accessing the Windows 7 Partition from within Mac OS (I can still boot into windows perfectly fine on startup though). I can neither see the Partition in the Finder, nor do Parallels Desktop or VMWare Fusion work. Disk Utility shows my Windows partition as "disk0s3", it's greyed out and not mountable. For some strange reason it says that it's Mac OS Journaled (Extended), while I'm 100% sure that it's NTFS (because this was what I formatted it with and that's also what Windows is displaying).

Any way of getting the access back other than re-installing everything?

Thanks in advance, I really appreciate any possible help!

04-08-2011, 02:35 PM
Two things you can try: First, try resetting the PRAM - NVRAM. LINK (http://support.apple.com/kb/HT1379) That may not work but worth a try.

Second, you might consider installing rEFIt (http://refit.sourceforge.net/) and let it handle the booting.

04-09-2011, 06:03 AM
I tried both, unfortunately neither helped...
What I see when i'm trying to verify the disk is that it spits out an error saying "Invalid B-Tree Node Size". I tried fixing it using DiskWarrior but then it gives me this:
http://www.abload.de/thumb/screenshot2011-04-09atdhf8.png (http://www.abload.de/image.php?img=screenshot2011-04-09atdhf8.png)

Does that mean that it will erase the whole partition after that step? When it previewed the drive in the finder it was all empty.

04-09-2011, 10:08 PM
The "Invalid B-Tree Node Size" error is fatal. You can't recover from that without doing an erase, re-format, and re-install. It probably overlaid some partition information to another. In other words, you likely have overlapping partitions. That's why it's misidentifying the partition type.

I used to be able to dig around with a hex editor and fix those but with today's modern large drives and partition tables, it's just easier to re-install.

Hopefully you have some sort of a backup that you can restore from otherwise most of that data will be lost.