View Full Version : How to time machine restore folder with it's contents?

03-05-2011, 03:50 AM

I know how to restore individual items from a time machine back up. But I want to restore a folder with all it's folder contents. And when I try to restore the folder, the folder is restored and empty. I have to them go back into time machine to restore the files in the folder.

Is there a way to restore a folder and it's contents at the same time with time machine?
And yes it asks me for my password each time I restore the individual files.

And now when I try to restore a folder it just says I don't have permission to access the folder and it just restores the empty folder. But I can access and restore the individual folders. Strange.

03-05-2011, 04:23 AM
Are you opening the folder in Time Machine and selecting all its contents first before dragging and dropping? I just did this the other day with my entire iTunes library (don't ask) and it worked fine.

Getting late - got lots to do Saturday.... Will get back to you later in the day.

03-05-2011, 05:07 AM
No I didn't do that, I just selected the one folder and thought it'd restore the folder with contents. But no luck. I'll try what you said and get back to you if it works. Cause I think this just might be something a new user/switcher might need to know.

And thanks for the reply.

[edit] That didn't work. You can not select the files inside a folder and the folder itself at the same time. I tried it in column finder view in time machine and selected the folder and in the next column it's contents, but only the multiple files selected were restored. I just want to know is it possible to select a folder and have all that folders contents restored? And if so how?

03-05-2011, 06:18 AM
Just ran a test here.

Created a new folder - put the contents of another folder in it - did a TM backup - deleted the new folder and emptied the trash - opened Time Machine - highlighted the folder - clicked restore - and it restored the folder and all 426 items within the folder.

edit: I was in list view in the TM backup vs column view - though I doubt that should make a difference.

edit 2: yep, just did the same from column view, highlighting the folder only and it still restored the folder and all contents.

edit 3: are you opening the TM backup within Finder or are you using the 'Enter Time Machine' function from the shortcut menu of Time Machine on the menu bar?

03-05-2011, 06:56 AM
I went to the menu bar top right hand side and on the TM icon there I clicked "Enter Time Machine". And I went to it's usual space view. And did the restoring from there.

And I don't think I can open my TM backup from the desktop. My external is in 2 partitions. One for general stuff and the other for TM. On the side of finder windows the Non-TM partition is there but the TM partition is not there. So I dan't directly access it in the finder.

This might be a permissions issue as I get permissions errors when I try to restore a folder. But how do I repair permissions on an external drive. Dink utility will only let me repair permissions on the internal drive. I did a repair of the external drive. But that didn't help at all.

So I'm stumped as to why I'm getting this issue.

03-05-2011, 09:52 AM
What's the specific error?

Only guessing here... Check the permissions of the folder on your system drive that you're trying to restore into. Ex. Trying to restore 'Folder1' that was located in your 'Documents' folder. Verify you have read/write access to 'Documents'.

03-05-2011, 05:35 PM
This works for me likewise just as bobtomay pointed out. Now that I think about it, when I restored the iTunes library that's probably what I did although I seem to remember selecting everything at once.

The reason I remember it that way is Time Machine gave me an overwrite warning before proceeding.