View Full Version : Help Importing Video Into iMovie

07-29-2010, 09:40 PM

I have spent the last few days searching for answers regarding why my new imac doesn't recognize the movie files on my sony hd-sr11 camcorder.

According to the posts I've read on this forum and the support docs on the mac page, my new intel based 21.5 mac 10.5 os should recognize the avchd files on my camera. But when I connect my camcorder to the imac, iphoto recognizes the 20 or so "photos" that were taken. When I close iphoto and open imovie i can not import the movies no matter what I do.

According to the tutorial, all I am supposed to do is click the camera icon on the left side of the program that says import from camera. All this does is pull up the built in camera in the imac and asks me to capture/record. Where the in-imac camera is listed it looks like I should be able to select another camera source but there are no more options available.

When I go to file/import and navigate to the "no name" device that is my camcorder, the files are grayed out and will not import.

Does anyone have any suggestions???? I am stumped.


07-30-2010, 06:27 AM
Next time, do a search before posting per the community guidelines.

This has already been asked and answered (http://www.mac-forums.com/forums/movies-video/136723-importing-sony-hdr-sr11-imovie-hd-08-a.html).

07-30-2010, 08:53 AM
Chas, as I stated in my original post....I have searched and read these posts that you have linked.

My imac does not prompt me to import. None of the "solutions" seem to pertain to my issue. If there is a post with mts, sony import, etc I have read it.

Firewire has been thrown out as a potential solution, but there are many who describe using the usb with no problems. I use the docking station, keep continuous power going to the camera and still get no prompt from my imac.

iphoto does pop up every time but there is nothing to import.

07-30-2010, 10:06 AM
Remove the photos from the cameras storage, on some cameras it has happened where when there are both photos and video, iMovie will not properly import the video. If the video is stored in a separate folder structure from the DCIM you can even try deleting the DCIM folder.

07-30-2010, 12:39 PM
thanks. photos have been removed previously after seeing this in other peoples solutions. I will try removing the folder if nothing else works.

Currently I have the camera connected and the mac is doing a "wait-type of icon" with a circle of lines that keep going round and round. i spoke with a mac app specialist and he said that it can take an hour for imovie to load the data to first give you the prompt to import. Right now it has been doing this waiting for nearly 3 hours.

I do have a lot of video stored on the hdd so i will continue to wait.

If anyone has any other input I would appreciate it!

07-30-2010, 06:29 PM
After 7 hours, no prompt from imovie.

Removed DCIM folder and tried again. Nothing.

Now the waiting icon does not appear when I reconnect via docked usb.

Any suggestions?