View Full Version : AirPort Connects - but isn't :/

12-13-2008, 07:04 AM
Okay here's the deal:

I just recently purchased a BELKIN Wireless Router. My MacBook Pro can find it and connect to it at full strength. So I open safari and it says you are not connected to the internet.. This is strange because the wireless works with my PS3 and my PSP. I would love some help please on how to fix this.

12-13-2008, 07:29 AM
Are you using Encryption on the router? Is so which type, WEP, WPA, WPA2?

If you open System Preferences and Network and click on Airport, what IP Address is listed?

12-13-2008, 09:14 AM
I'm using WPA2.. and the IPv4 address is

Also I thought I should mention that the subnet mask says

(It also says this: AirPort has a self-assigned IP address and may not be able to connect to the Internet.)

12-13-2008, 09:33 AM
Make sure Configure iPv4 is set to: Using DHCP

Then hit the Renew DHCP Lease button

What happens then?

And I am assuming you have added the network you created on the Belkin to the Preferred Networks of your Airport.

(And dtravis is better at networking than I)

12-13-2008, 10:45 AM
Thanks guys for your help, but it randomly worked.. I didn't change anything it just randomly worked :/ thanks anyways.