View Full Version : VERY unusual Time Capsule/Windows problem

03-31-2008, 01:18 PM
I've had windows pc's for a long time and a linux only pc for a year. Just bought first Mac and finding it a very interesting machine. I need to integrate the iMac into a windows environment, so I set up a Time Capsule as the primary router for the network. The TC is connected to Verizon DSL. The iMac was successfully connected wirelessly to the TC and to the internet. WPA2 encryption is used.

The former windows only network router, a Netgear, was successfully bridged to the TC using an ethernet cable from a Netgear ethernet port to a TC ethernet port, port #1 (of 3), and a windows xp pro laptop successfully acquired an IP address from the Netgear and connected to the internet. (The reason the Netgear was kept is that the xp pro laptop has an old wireless adapter that cannot use WPA encryption.)

A windows vista laptop successfully acquired an IP address from the TC and connected wirelessly to the internet - using WPA2 encryption.

Now, the problem.
There is an xp pro desktop to be connected to the TC via ethernet cable. It has no internal wireless adapter and no usb ports available for an external wireless adapter. The xp pro desktop was connected to the #2 (of 3) ethernet port on the TC. It could not acquire an IP address from the TC.

Consulted with Apple OneCare tech and spent 3 hours troubleshooting.
1. Tried different ethernet cable from xp pro desktop to TC - no solution.
2. Connected xp pro desktop directly to DSL - acquired IP address and accessed internet.
3. xp pro desktop has one primary user account and one admin account. Booted in safe mode using primary user account no IP address.
4. Created new admin user account new account acquired IP address and accessed internet using same #2 ethernet port on TC.
5. Using primary user account, deactivated firewall (Zone Alarm) and all Norton utilities. No solution.

Apple OneCare tech decided to call in a senior tech. While waiting for senior tech disconnected. Have not contacted Apple OneCare again, yet. Will do so soon.

Independently of tech support-
6. Switched Ethernet cable from xp pro desktop from port #2 to port #3 of TC. Original primary user account briefly acquired IP address and accessed internet and then lost IP address.

To summarize-
1. Ruled out bad Ethernet cable from xp pro desktop to TC.
2. Ruled out bad xp pro desktop Ethernet card (had also run successful loopback ping test).
3. Access by another user account seems to point to some application in original primary user account causing interference, but switching Ethernet cable to different TC port seems to rule that out.
4. Access by connecting xp pro desktop to different TC Ethernet port seems to point to faulty TC Ethernet port #2, but fact new user account could connect via TC port #2 seems to rule that out.

So, while a Mac pc and a windows laptop acquire IP addresses from the TC using wireless and connect to the internet, and a windows laptop acquires an IP address wirelessly from a bridged Netgear wireless router and connects to the internet, a windows desktop connected via Ethernet cable to the TC cannot acquire an IP address from the TC and thus cannot connect to the internet.

It might be best to wait until contact with Apple OneCare tech support, but perhaps someone on the forum might have a useful insight into this very strange problem.

04-06-2008, 10:53 AM
This problem was solved, although I can't say I know why it occurred.

The windows XP laptop had an older laptop adapter, 802.11b, that could not work, using wpa encryption, with the Time Capsule's 802.11g/n, which is what required the use of the 802.11b Netgear router bridged to the Time Capsule.

STEP 1 - replace the 802.11b wireless adapter in the windows xp laptop with an 802.11g adapter. This allowed the windows xp laptop to acquire an IP address from the Time Capsule but not access the internet.

STEP 2 - remove the 802.11b Netgear router from the network.

At this time, iMac was acquiring an IP address from the TC but not accessing the internet. This led to questioning whether the ethernet cable from the TC to the DSL device was a problem.

STEP 3 - Replaced that ethernet cable from the TC to the DSL device and both the iMac and windows xp desktop accessed the internet.

STEP 4 - With the 802.11b Netgear router now removed, connected the windows xp desktop to the TC with ethernet cable. Windows xp desktop then acquired an IP address and accessed the internet.

SUMMARY: it seems that there may have been two problems.
1. The 802.11b Netgear router bridged to the TC via ethernet.
2. A faulty ethernet cable between the TC and the DSL device.

I hope this may help anyone else troubleshooting a similar problem. Neither Apple OneCare nor anyone viewing the original posting was able to provide any help, although by working with the Apple tech, enough insight was gained that a solution eventually came from trial and error.

Now beginning to enjoy the full use of the iMac and expecting to make very good use of a very nice machine.:)