View Full Version : USB Hub causes wireless internet to drop - webpage wont load

03-31-2008, 06:36 AM
i've finally isolated this problem.
ive got a belkin 7 port USB hub attached to my mini and use a belkin wireless router.

plug any active device into the hub and my webpage wont load. it just hangs.
plug out usb device and refresh page and it works.

03-31-2008, 10:30 AM
Wow, that's weird. You don't use an external USB wireless adapter do you?

03-31-2008, 10:37 AM
im using a belkin wireless modem/router. my mac connected by airport to this.

previous to that i was using a ZyXel wired modem and had my mini connected to the web by ethernet and there was no problems with the hub then.

it seems to cut the wireless completely as a webpage wont load on my macbook either.

cant understand how its interfering with the wireless.
ive tried changing the wireless channel but now luck there.

04-02-2008, 07:24 AM
its actually the power adapter to my usb hub that causing the problem. tried it without power adapter. also used a multi - adapter power supply and it works fine with that.

will have to ask belkin for a new power supply

12-29-2008, 03:34 PM
Have Linksys wireless (2.4Ghz [B/G]) router (WRT54G v6) connected to MAC. Can print once to HP laser (USB attached printer). Subsequent prints don't work although MAC print dialogue box shows "printing". Restarted MAC and HP laser, still no print. Power cycled USB hub, began printing that job. Subsequent prints did not work. Finally removed Linksys and plugged MAC into DSL modem, still same issue. Removed power from Linksys (stopped 2.4Ghz wireless transmission) and printing worked fine. I think the 2.4Ghz signal is interfering with the USB hub somehow. Next step is to replace USB hub and look at better, shielded USB cables.

Anyone experience or seen this type issue?