Please visit the new Mac-Forums Facebook page:
https://www.facebook.com/macforums1




Results 1 to 3 of 3
  1. #1
    2010 Macbook Pro Hangs after initial "boot"/loading screen
    hi all,

    i'm a fairly newbie to the mac scene, although i have run a few in the past... just haven't really dug into the "depths" so - to - speak.

    I inherited a 2010 Macbook Pro with 8GB RAM but no HDD. I added a SATA HDD and started to boot from the internet recovery option. I'm able to connect to the internet, the download occurs, and then it starts the "boot" sequence, so I have the mac icon and the status bar at the bottom. Once the status bar reaches 100% the screen "blanks" for a second then goes to the standard grey background. Here however, nothing happens, not ever. It just sits there idle. I've left it overnight - nothing.

    So, I tried to run Apple Diagnostics, same thing happens.

    I removed the HDD (SSD actually) and tried the same thing - again - loads 100% with no errors nor kernel panics, but as soon as it refreshes to give me any sort of installer or desktop / etc., it just sits there and won't go forward.

    I've tried booting from a known-good OS X Sierra installer DVD, same thing happens.

    Anyone seen anything similar? I've reset the PRAM and SMC, tried different HDDs and SSDs. And tried swapping out memory - still no difference.

    I'd hate to think that the System board or MB is bad... because then I'd expect it to give me much more non-specific errors, but then again, I have no idea.

    Any suggestions? PS: Safe Mode didn't show much either, but I did try verbose mode and got some output that I can upload (it's a MOV file of it booting), if anyone thinks it would be helpful. My only other mac right now is a macbook 1,1 running OS X 10.6.8.

  2. #2
    2010 Macbook Pro Hangs after initial "boot"/loading screen
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    58,252
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    Welcome to our forums.

    You didn't state which model 2010 MacBook Pro you have, but it should have come pre-loaded from the factory with Snow Leopard 10.6.3.

    I've tried booting from a known-good OS X Sierra installer DVD, same thing happens.
    There is no such thing as a Sierra installer DVD as Sierra is only available from Apple as a download.

    Also, I don't believe you can do an internet recovery install for that machine as Snow Leopard is still available as a DVD purchase from Apple. ($19.99 from the online Apple Store)

    Buy the Snow Leopard DVD from Apple, and also purchase a new SATA cable (hard drive to logic board) from either iFixit: The Free Repair Manual or Apple Mac Upgrades - RAM, SSD Flash, External Drives and More. If the optical drive on that machine is good, you should be able to get things going that way. Once you get Snow Leopard installed and things working right, you can then upgrade macOS to 10.13.6. (High Sierra)

  3. #3
    Quote Originally Posted by chscag View Post
    Welcome to our forums.

    You didn't state which model 2010 MacBook Pro you have, but it should have come pre-loaded from the factory with Snow Leopard 10.6.3.



    There is no such thing as a Sierra installer DVD as Sierra is only available from Apple as a download.

    Also, I don't believe you can do an internet recovery install for that machine as Snow Leopard is still available as a DVD purchase from Apple. ($19.99 from the online Apple Store)

    Buy the Snow Leopard DVD from Apple, and also purchase a new SATA cable (hard drive to logic board) from either iFixit: The Free Repair Manual or Apple Mac Upgrades - RAM, SSD Flash, External Drives and More. If the optical drive on that machine is good, you should be able to get things going that way. Once you get Snow Leopard installed and things working right, you can then upgrade macOS to 10.13.6. (High Sierra)
    Thanks - I thought it could be the SATA cable... this one actually looks a bit jacked up. I'll try a new one and follow your advice in terms of starting with Snow Leopard and will post results. Thanks again!

    Cheers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 05-12-2017, 10:11 AM
  2. 2010 Macbook pro 13" shuts down during boot up
    By JanuszK in forum Apple Notebooks
    Replies: 11
    Last Post: 11-08-2015, 09:26 AM
  3. MacBook Air - Grey Screen on Boot, "OLD MAC" Message Appears
    By ratsintheattic in forum Switcher Hangout
    Replies: 4
    Last Post: 10-15-2014, 12:14 AM
  4. MacBook Pro 2010 15" won't boot for anything
    By morrisj6 in forum Switcher Hangout
    Replies: 2
    Last Post: 05-21-2011, 02:46 AM
  5. windows computer hangs at boot screen with "58"
    By coach_z in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 12-12-2007, 09:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •