Results 1 to 3 of 3
  1. #1
    2010 iMac boot problem
    Hi.... I have a 10 year old iMac. When I switch it on, the grey apple screen comes on as usual, but then it goes to a red screen, then a purple screen with a yellow pattern then to black. On the black screen I can still see the spinning beach ball and the the cursor, as normal. If left for a while, it will usually try to restart. When I go into safe mode, it works, though the screen flickers a lot. I've already re-downloaded the last version of the OS which works. Any thoughts on what might be the issue? GPU? Age? I know I probably need to get a new machine, and having got 10 years out of this one, I'll likely go for another iMac, but if I can fix this and give it to my kids that'd be great!

  2. #2
    2010 iMac boot problem
    pigoo3's Avatar
    Member Since
    May 20, 2008
    Location
    U.S.
    Posts
    41,648
    Your Mac's Specs
    2011 17" MBP 2.2ghz, 16gig ram, OS 10.11.6
    Rep Power
    43
    Quote Originally Posted by Brucebhoy View Post
    GPU?
    Whenever you have strange video issues as described...GPU is definitely a prime suspect. If this is an iMac with dedicated graphics hardware (has separate video hardware)...not integrated graphics. In the past I've had some luck repairing video issues by removing the video card heatsink...replacing the thermal paste between the GPU and heat sink...and reassembling.

    No guarantee's of course...the video hardware in this iMac may have failed...and that is that.

    If you wanted to pursue this possible repair...we would need to know exactly what model iMac this is.

    - Nick
    - Too many "beachballs", read this: Beachballs
    - Computer seems slower than it used to? Read this for some slow computer tips: Speedup
    - Almost full hard drive? Some solutions. Out of Space
    - Apple Battery Info. Battery

  3. #3
    First, Nick, thanks for taking the time to reply.

    A few more details - the screen works when in safe mode. When I'm on chrome, it flickers when I type or scroll. Especially around the cursor. It doesn't flicker at all when I have other things open, like Word. Bizarre. Would that still happen

    I had been thinking about getting a new iMac anyway. I'm nowhere near technically proficient to attempt taking it apart and I doubt I have the tools I'd need.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iMac Mid 2010 Firmware Update And Ram Problem
    By jasongoldworthy in forum Apple Desktops
    Replies: 9
    Last Post: 12-23-2019, 08:30 PM
  2. Imac Boot Problem
    By divadyblik in forum macOS - Operating System
    Replies: 1
    Last Post: 12-05-2014, 11:22 AM
  3. Replies: 1
    Last Post: 11-03-2012, 04:41 PM
  4. No sound in Windows 7 after Boot Camp (IMAC MID 2010)
    By mellocakes in forum Running Windows (or anything else) on your Mac
    Replies: 6
    Last Post: 08-30-2010, 09:15 AM
  5. Imac 233 boot problem
    By jabberwock486 in forum Apple Desktops
    Replies: 0
    Last Post: 02-03-2005, 02:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •