Please visit the new Mac-Forums Facebook page:
https://www.facebook.com/macforums1




Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 32
  1. #16
    Bluetooth Not Detected by iMac in System Informations
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,050
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    Every time you boot and the BT keyboard does not work does also System Info show no BT also? I wish you had an external back up of the Mac OS you could boot from and see if the issue is still there.

  2. #17
    Bluetooth Not Detected by iMac in System Informations
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,050
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    One more thing I forgot to say, I can not see how any SSD driver would interfear with BT as the drive is on the SATA bus and has nothing to do with BT. Strange one for sure.

  3. #18
    Quote Originally Posted by dtravis7 View Post
    One more thing I forgot to say, I can not see how any SSD driver would interfear with BT as the drive is on the SATA bus and has nothing to do with BT. Strange one for sure.
    I heard that SSD Drive may interfear magnetically with Bluetooth radiations. Some users solved the issues by wrapping their ssd into foil paper.

    Quote Originally Posted by dtravis7 View Post
    Every time you boot and the BT keyboard does not work does also System Info show no BT also? I wish you had an external back up of the Mac OS you could boot from and see if the issue is still there.
    This is what happens, again:

    New Video 1 - Again -> Here the Bluetooth keyboard works when I have to select the hard drive to boot with.
    https://www.youtube.com/watch?v=B4InWjZS7E4

    New Video 2
    - Again -> Again, Bluetooth is working during the recovery installation mode.
    https://www.youtube.com/watch?v=2rfGqV64Hes

    Now I'm installing the OS, again, so I'm not able to tell you if Bluetooth is going to work again when I'm into the OS. I'll let you know.

    P.S. When I previously had the OS installed, the Bluetooth icon disappeared from System Preferences, as well from system informations.

  4. #19
    Bluetooth Not Detected by iMac in System Informations
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,050
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    Keep us posted. I do know of users who have installed SSD's in a an iMac just like yours and reported no issues. I hope you can solve this. I will do more searching and report back if I find anything.

  5. #20
    Quote Originally Posted by dtravis7 View Post
    Keep us posted. I do know of users who have installed SSD's in a an iMac just like yours and reported no issues. I hope you can solve this. I will do more searching and report back if I find anything.
    Here I am.
    I left you with the first 2 videos in which the bluetooth keyboard was working during recovery mode/installation process of the new os...

    I waited for the whole process to complete and then this just happened:

    Video 3 - Not working after installation
    https://www.youtube.com/watch?v=YX_KfL2Rda0

    There's no logic behind all that. It's crazy that everything works before installing the OS and then it doesn't work anymore.

    Please watch the video if you can.

  6. #21
    Bluetooth Not Detected by iMac in System Informations
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,050
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    The videos play fine here. I think the other users ISP was not showing them for some reason.

    Anyway that is crazy for sure. When you get into the new OS is BT still missing in system info? How about system Preferences??

    Still searching for a solution.

  7. #22
    Quote Originally Posted by dtravis7 View Post
    The videos play fine here. I think the other users ISP was not showing them for some reason.

    Anyway that is crazy for sure. When you get into the new OS is BT still missing in system info? How about system Preferences??

    Still searching for a solution.
    Of course. It is still missing.

    It's crazy that I can use Bluetooth only during the installation process :/.

    EDIT: What do you recommend for what concern hard drive formats? I formatted my internal SSD as APFS and my old Mechanical Hard Drive in macOS Journaled.

  8. #23
    Bluetooth Not Detected by iMac in System Informations
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,050
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    I was wondering something. Since you did read somewhere some SSD's can cause interfierence with BT, have you tried removing the SSD and booting into the OS without the SSD there and see what happens? Just curious and trying to help.

    On formatting I have one of my iMacs set up that way, Boot drive is APFS and 2nd drive Mac OS Journaled. Works great.

  9. #24
    Quote Originally Posted by dtravis7 View Post
    I was wondering something. Since you did read somewhere some SSD's can cause interfierence with BT, have you tried removing the SSD and booting into the OS without the SSD there and see what happens? Just curious and trying to help.

    On formatting I have one of my iMacs set up that way, Boot drive is APFS and 2nd drive Mac OS Journaled. Works great.
    I haven't tried what you're questioning, because that wouldn't be a valid solution for me. I mean: the whole aim of the entire operation is having the OS loaded on the SSD Drive, which, in my opinion, is more important than Bluetooth capabilities.
    Even if the problem is really caused by the aformentioned interfereance I'm not going to remove the SSD just to have Bluetooth back. I hope this is making sense.

  10. #25
    Bluetooth Not Detected by iMac in System Informations
    MacInWin's Avatar
    Member Since
    Jan 01, 2009
    Location
    Winchester, VA
    Posts
    6,048
    Your Mac's Specs
    MBP 15" Mid 2015, iPhone XS, an iMac, plus ATVs, AWatch, MacMini
    Rep Power
    26
    How about removing the SSD, test if the BT works without it in and if it does, that would point to the SSD as a source of some sort of problem. If it doesn't work even with the SSD removed, then the SSD would be eliminated as a potential source. At this point you have no idea what is the cause.

    If it is the SSD, you can still have an SSD in the Mac, just get a different brand/model.
    Jake

  11. #26
    Exclamation
    Quote Originally Posted by MacInWin View Post
    How about removing the SSD, test if the BT works without it in and if it does, that would point to the SSD as a source of some sort of problem. If it doesn't work even with the SSD removed, then the SSD would be eliminated as a potential source. At this point you have no idea what is the cause.

    If it is the SSD, you can still have an SSD in the Mac, just get a different brand/model.
    These are some images from System Information:







    This is an SSD Speed Test. I was wondering if it was too slow or not:



    _____________

    Ok.
    I'm going to try removing the SSD in few hours, just to see if it is it's fault.

  12. #27
    Bluetooth Not Detected by iMac in System Informations
    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    5,581
    Your Mac's Specs
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS High Sierra 10.13.6
    Rep Power
    18
    Quote Originally Posted by Bacchinif View Post
    Check them now.

    Working now. Thanks very much.

    Ian
    Ian

  13. #28
    Exclamation
    Quote Originally Posted by IWT View Post
    Working now. Thanks very much.

    Ian
    Here I am, with a little update.

    As requested, I decided to re-open the machine in order to remove the SSD Drive. So I did, but, unfortunately, when I turned on the iMac again I got a very bad black screen. I don't know why was that (maybe because the OS was installed on the SSD just removed?), but then I put the SSD back again.
    Turned on the Mac one more time and suddenly the Bluetooth icon came back to life, as well all the informations under System Profiler.

    At the moment I'm re-installing OS X again after formatting the SSD in APFS, and I really HOPE that Bluetooth is going to work back again.

    Here some images of what I did:







    As just described I did some cleaning inside using an hairdryer in order to remove some dust.
    I turned the Mac on and finally Bluetooth was back again like this:





    At the moment I'm installing OS X back again. I'll let you know if everything stays the same like in the previous two images.

  14. #29
    Bluetooth Not Detected by iMac in System Informations
    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    5,581
    Your Mac's Specs
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS High Sierra 10.13.6
    Rep Power
    18
    I do admire people like you who can take their Mac apart and replace this and rebuild that.

    Anyway, fingers crossed it works for you.

    Ian
    Ian

  15. #30
    Bluetooth Not Detected by iMac in System Informations
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,050
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    Fingers crossed here also.

    I found a lot of threads with your issue but every one was an MBP with the BT Module right next to the DVD drive bay. Yours is on the other side of the iMac so I doubt that is the issue. Keep us posted!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. informations share via USB cable
    By atomottokar in forum Apple Notebooks
    Replies: 1
    Last Post: 01-17-2014, 04:51 PM
  2. Malware detected on my iMac!
    By Cal30M1 in forum macOS - Operating System
    Replies: 1
    Last Post: 10-06-2010, 09:33 PM
  3. Battery informations in Leopard 10.5.7
    By russell23 in forum macOS - Operating System
    Replies: 4
    Last Post: 06-04-2009, 02:38 AM
  4. iMac hard drive not detected after installed XP
    By gagliano3 in forum Running Windows (or anything else) on your Mac
    Replies: 19
    Last Post: 05-19-2009, 01:49 PM
  5. imac G3 HD not detected
    By cypressguy in forum Apple Desktops
    Replies: 2
    Last Post: 03-13-2009, 06:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •