PDA

View Full Version : Stopping automatic archive in mail



minibill
01-25-2017, 09:22 PM
Can I stop mail from automatically archiving mail every time I receive new E-mail? When I deleted the archive folder it also deleted my in box. Would like to not have this happen again. What about getting rid of the archive folder? If possible how do I do that?
Bill

pm-r
01-25-2017, 11:36 PM
Can I stop mail from automatically archiving mail every time I receive new E-mail?


You're going to have to supply some more info and details in order to get a proper reply, like at least what version of Mail you're using…

and maybe some details as to what you're doing or did… and wanting to do…






- Patrick
==========

minibill
01-26-2017, 12:26 AM
mail is version 9.3 (3124). I wanted to delete all the archived mail and after I did and went back to my in-box all mail there apparently had been deleted. I would like for this not to happen. I really don't see that I have much use for archived mail.
bill

I need to clarify my original post. I did not delete the archive folder, I deleted all the entries in it. If I could delete the folder that would be great (I think).. Cant find an option to delete the folder.

chscag
01-26-2017, 02:39 AM
The current version of Mail is 10.2 but the behavior of the archived folder should be the same in version 9.3. You need to tell us who your ISP is and what mail protocol you're using. It sounds like your Mail account is an IMAP account which means the archived folder on the server is duplicated on your Mac. If that's the case, deleting mail from the archived folder will result in the mail being removed from your inbox.

IWT
01-26-2017, 05:23 AM
@minibill

To follow on from Admin chscag's helpful comments:

I have Apple Mail 10.2 running on an iMac with macOS Sierra. My accounts are also IMAP.

Against the Archive Mailbox, I have an exposure triangle which, when opened yields three places where mail may be archived - see image below. In my case On My Mac (which keeps the archived emails, as the name implies, on my iMac); iCloud and btinternet (which is my ISP). In the latter two cases, the archive is web-based in relation to my iCloud email account or my Btinternet account, respectively.

If I delete mail from either of the web-based archive accounts, these are removed from my iMac; but I can do what I like with the mails stored locally On My Mac.

Does this, in any way, seem familiar to you as regards your setup?


25752

Ian

minibill
01-26-2017, 11:00 AM
Answers to above questions:
My ISP is Time-Warner (now Spectrum).
The Time-Warner protocol is POP3.
I'm running El Capitan.
My archive mailbox has 2 options under the exposure triangle, Google (all mail) and Time-Warner. Everything is automatically archived under Google (all mail).
What I am trying to do is get rid of the archive folder completely. I see no use for it.
bill

IWT
01-26-2017, 01:14 PM
Hello again, Bill

Thanks for the additional info.

Re-reading your first post, I was slow to pick up on the fact that, apparently, every new email you get goes to the Archive folder. Why?

Obviously, everybody arranges their Mail mailboxes and setup individually; but however you arrange it, I've never heard of new emails being automatically put in the Archive folder - unless you created a rule for that - or - it's a feature unique to a particular email Account; even then, there should be a way of disabling that feature.

As I have - certainly up till now - understood things, you have to drag an email manually into the Archive Folder or Select a message/group of messages and then choose Message > Archive

An Archive is created for each account you have.

So, that's the first thing I don't understand.

Secondly, I have not found any way of deleting these Archive Folders.

My comments above apply equally to POP3 and IMAP protocols.

Ian

minibill
01-26-2017, 01:37 PM
Thanks Ian
You are correct, every new e-mail goes to the archive folder. I have not created any rules. All settings are as they came on my computer. It's a Mac mini bought new.
bill

chscag
01-26-2017, 05:42 PM
In addition to what Ian said, it appears you actually have two accounts. One with Charter Spectrum, the other with gmail (google). POP 3 mail does not act that way which again leads me to believe that one of those accounts is IMAP. Maybe gmail?

pm-r
01-26-2017, 06:45 PM
I wonder if there's anything that would help in this Apple article???:
Mail for Mac: Archive messages in Mail
https://support.apple.com/kb/PH22307?locale=en_US&viewlocale=en_US






- Patrick
==========

IWT
01-26-2017, 06:58 PM
@Patrick

Nice article and bang up to date. Basically matches my comments and the point that to Archive requires the user to initiate the process. The OP says that all new emails automatically go into the Archive Folder. I can understand why deleting them from there would remove them from the Mac especially if an IMAP account; but I can't work out why the messages go straight to Archive by default.

Ian

pm-r
01-26-2017, 07:38 PM
but I can't work out why the messages go straight to Archive by default.


Yeah, without a rule, there must be some other setting or preference that's messed up or confused, or doing exactly as it's told that has been missed when checking???

I just tried a search and got some related hits, but didn't see anything definitive but go ahead and look if anyone wants to:
https://www.google.ca/search?client=safari&rls=en&q=mac+Mail+in+messages+go+straight+to+Archive+by+d efault&ie=UTF-8&oe=UTF-8&gfe_rd=cr&ei=E4aKWLGsL6fP8gfM-7r4BA

and
https://www.google.ca/search?client=safari&rls=en&q=mac+Mail+in+messages+go+straight+to+Archive&ie=UTF-8&oe=UTF-8&gfe_rd=cr&ei=woiKWObQBMTM8geq7ZuYAg


Edit:
I think I'd be double checking the Mail Preferences Rules thoroughly or try creating one to put all new email messages to my appropriate In mailbox.
Secondly, I think I'd try Rebuilding all mailboxes, just in case it might help. Can't hurt I don't think.







- Patrick
==========

minibill
01-26-2017, 07:51 PM
In addition to what Ian said, it appears you actually have two accounts. One with Charter Spectrum, the other with gmail (google). POP 3 mail does not act that way which again leads me to believe that one of those accounts is IMAP. Maybe gmail?

Yes, I have 2 accounts and one is g-mail.

pm-r
01-26-2017, 08:26 PM
Yes, I have 2 accounts and one is g-mail.


Are both accounts acting the same way and sending all new incoming email messages to an archive???

You can test each by sending yourself an email to each account, and you might want to try using each account to do so.

BTW: Gmail came up many times in the google search hits URL I posted above of those with similar problems you might want to check out.






- Patrick
======

minibill
01-26-2017, 08:29 PM
I have read the Apple help articles and some of that stuff is a little over my head. After some experimenting I have found out that when I delete what's in the trash folders it also deletes it from the archive folders. Knowing that, I think I'll leave things alone and just delete from trash.
bill

minibill
01-26-2017, 09:05 PM
Patrick,
I did the test account to account both ways and the messages showed up in the proper in-boxes. However they both showed in the Google (all mail) archive folder. Think I'll leave things alone for a while. Seems like this is pretty common after searching google a little.
bill

chscag
01-26-2017, 09:24 PM
However they both showed in the Google (all mail) archive folder. Think I'll leave things alone for a while. Seems like this is pretty common after searching google a little.

That tells us that your Google account is IMAP. You can change that from settings at the Google Mail (gmail) web site. Or, you can switch your gmail account to POP and you won't have that problem.

minibill
01-26-2017, 11:28 PM
That tells us that your Google account is IMAP. You can change that from settings at the Google Mail (gmail) web site. Or, you can switch your gmail account to POP and you won't have that problem.

Not sure how to switch the Google account.

IWT
01-27-2017, 03:51 AM
Apologies. I originally posted in the wrong place - that is, right thread but didn't realise there was a page 2. My error.

Ian