PDA

View Full Version : Error messages - iphone to imac



Timmer69
12-26-2016, 08:18 AM
When I plug in an iphone to the mac desktop in order to sync music or photos, I get an error message that says....'iTunes could not connect to the iPhone "Tim's iPhone" because an invalid response was received from the device'... and 'Photos in the Camera Roll of "Tim's iPhone" cannot be imported because the devise is locked with a passcode. You must unlock the devise to import them.'
Neither of these messages have appeared in the past. Tried to find and use the passcode they're talking about. No luck. Not sure how to proceed. Thanx Tim

IWT
12-26-2016, 08:59 AM
Hi Tim

A warm welcome to Mac-Forums.

There is only one "Passcode" and that is the code you use to unlock your iDevice.

However, there may be other issues because the messages you got should not happen.

One thing to check - make sure that you have a secure USB connection direct to a port on the Mac, not via a hub.

Another thing to consider is a hard reboot of your iPhone. (Done by holding down the Power and Home buttons together and continue doing so until the iPhone shuts down and the the Apple icon appears).

Then try again.

Please post back. We are here to help.

Ian

ferrarr
12-26-2016, 10:45 AM
I have also noticed some cables (non Apple) do not always work correctly. We have a few around the house.

Timmer69
12-27-2016, 10:21 AM
No go on the hard reboot.....same messages....using a mac cable as well......

MacInWin
12-27-2016, 11:29 AM
Try restarting the iPhone.

https://support.apple.com/en-us/HT201559

Note: Only restart, not a force restart. The latter will erase everything on the iPhone. A simple restart should not.

IWT
12-27-2016, 12:06 PM
Jake, the OP has already done a hard/force restart as advised by me (post #2) - and it doesn't erase anything. It didn't help either!

I've done this on several phones where there were problems that wouldn't go away - it's frequently worked and all data, apps and the rest are preserved.

Ian

MacInWin
12-27-2016, 12:42 PM
Sorry, Ian, I missed the reboot of the iPhone. Normally that clears everything.

Timmer69
12-28-2016, 12:03 PM
Tried changing cables, as well.....same messages. Could this be a mac(destination) problem instead of an iphone(source) problem?