Results 1 to 5 of 5
  1. #1
    Late 2012 Macbook - disk utility sees drive, OS installer does not
    I recently purchased a new (to me) logic board because my old one crapped out due to liquid damage.

    After installing the new board disk utility could see my hard drive but the OS installer said that there wasn't one installed.

    I thought it was perhaps because my HD is SSD so I plugged in an external HD that was a standard drive.

    Again, disk utility saw both drives but then when I went to install the OS it indicated there weren't any drives installed.

    I even formatted and partitioned the external drive to see if I could get OS installed on it but got the same results.

    Has anyone else seen this behavior and know what might be going on?

    Any help would be most appreciated!

  2. #2
    Late 2012 Macbook - disk utility sees drive, OS installer does not
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, US
    Posts
    5,654
    Your Mac's Specs
    L2014 Mac mini macOS Mojave, iPhone 8+ iOS 12, 12.9" iPad Pro 1 iOS 12, Pencil 1
    When you "format and partition", you have to make sure the GUID partition is selected. Do you remember if that was the partition scheme you selected?

    You could always just Erase the drive with Disk Utility, and select GUID this time.
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  3. #3
    I'll have to check when I get home from work today but I'm pretty sure I selected GUID partition. I remember reading that I needed to ensure that I selected it so I made a point to check it.

    I'll give it another go just to make 100% sure.

  4. #4
    I went ahead and reformatted the external standard HDD again and made sure the GUID partition was selected and it still didn't work. Then I verified and repaired the disk and it worked perfectly.

    After that I installed mountain lion on the external drive and updated it to high seirra which gave me the firmware update I needed in order to get the board to see my internal ssd.

    It's now running great and all is well. Thanks for the help!

  5. #5
    PS... here's a better explanation of what was going on:
    https://www.ifixit.com/Answers/View/...rd+replacement

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 03-09-2015, 04:35 PM
  2. for a macbook air 2012, a utility to clean up hard drive?
    By henrycrnkovich in forum Apple Desktops
    Replies: 1
    Last Post: 10-23-2013, 07:09 AM
  3. New HD not showing up in Installer's Disk Utility?
    By raayymarr in forum Apple Notebooks
    Replies: 5
    Last Post: 06-27-2012, 02:33 AM
  4. Disk Utility only sees 157 gb on my 250 gig external
    By Doug b in forum Switcher Hangout
    Replies: 4
    Last Post: 07-23-2008, 01:33 PM
  5. Disk Utility from TIGER INSTALLER, want to make Image....?? help
    By NavyElk in forum macOS - Operating System
    Replies: 0
    Last Post: 07-09-2005, 01:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •