Results 1 to 4 of 4
  1. #1
    Mac Pro 3,1, PCIe SSD Boot Problems
    Hello,

    Wondering if someone could advise how to troubleshoot the following.

    I updated from El Capitan (not having the following problem), to Sierra (I'm on an unsupported machine for this OS, but used dosdudes patch, aside from the following issue everything works great). I seem to only be able to option key boot into my SSD, and get the circle with slash icon on straight boot up. I have reset NVRAM, I have replaced the NVRAM battery, Control selected the drive on option key boot, selected the drive in Startup Manager, and disconnected and reconnected the PCIe card (slot 2, directly above GPU in slot 1). I have removed all other drives and optical drives. The SSD (Crucial) is mounted on the Apricorn Velocity Solo x1 PCIe card. I also have a flashed GTX 680 2GB GPU installed. On option key boot, everything runs fine and the machine performs great.

    I know the 3,1 PCIe was always a bit flaky but not clear what might have changed going from El Cap to Sierra and/or if there is a way via terminal or verbose mode to troubleshoot this better or provide you folk the information to help me troubleshoot it better. Crucial's site is currently down for maintenance but I'm going to doublecheck to confirm I have the most current firmware on my SSD as soon as I can.

    Is it possible that this just won't work?

  2. #2
    Mac Pro 3,1, PCIe SSD Boot Problems
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    25,061
    Your Mac's Specs
    iMac, i7 4GHz, 32GB memory, 1TB Blade, OS X.14.2 Mojave,
    When I had a Mac Pro and looked at this, the suggestion was one could do one and one only kext update. Suggest inquiring over at Mac Rumours where they are more into Hackintoshes than here.
    Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  3. #3
    Hmmm, yea. I wonder if this has to do with the AppleAHCIPort.kext. This is all way above my head at this point, I'd imagine it's not safe to just yank the kext file from El Capitan and swap it out with the one from Sierra? I'll keep digging though.

  4. #4
    Checked the .fsck_hfs.log after boot up and saw the following:

    fsck_hfs.log

    /dev/rdisk4s2: fsck_hfs started at Tue Jan 15 16:10:28 2019
    /dev/rdisk4s2: /dev/rdisk4s2: ** /dev/rdisk4s2 (NO WRITE)
    /dev/rdisk4s2: Executing fsck_hfs (version hfs-366.70.3).
    /dev/rdisk4s2: fsck_hfs completed at Tue Jan 15 16:10:28 2019

    ** /dev/rdisk3s2 (NO WRITE)
    /dev/rdisk3s2: fsck_hfs started at Tue Jan 15 16:10:28 2019
    /dev/rdisk3s2: /dev/rdisk3s2: ERROR: volume / is mounted with write access. Re-run with (-l) to freeze volume.
    /dev/rdisk3s2: fsck_hfs completed at Tue Jan 15 16:10:28 2019

    Where disk4s2 is the one the machine should be booting into, it's booting to disk3s2 instead. Anyone know if that NO WRITE error is important?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Data Transfer: PCIe SSD to USB
    By NathanMcMahon in forum Apple Notebooks
    Replies: 1
    Last Post: 02-12-2016, 05:17 PM
  2. PCIe Flash Storage?
    By joeljen10 in forum Apple Notebooks
    Replies: 5
    Last Post: 05-03-2015, 02:25 AM
  3. Running a Mac Pro without a PCIE Fan?
    By harkkam in forum Apple Desktops
    Replies: 2
    Last Post: 11-09-2012, 11:13 AM
  4. eSata PCIe card
    By mknabster in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 10-22-2009, 05:12 PM
  5. pcie firewire card
    By nikonf8 in forum Apple Desktops
    Replies: 0
    Last Post: 08-25-2008, 10:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •