Results 1 to 12 of 12
  1. #1
    freaking website
    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    freaking website
    okay, so the website all went to crap

    same website as before http://www.bryantplayers.com/index.php

    i am basically just lost with this. so any help is appreiciated....everything is correct and the links it says it can not find are working

    -chris

    edit: edited link
    MoTM honor roll...
    when?
    i dont remember

  2. #2
    vtupser
    Guest
    One issue you might be having in your code is that when you are "including" external files that are HTML files, leave off any tags that open and close the html, body, and head. You have opened and closed html a bunch of times so it is screwing with the browser right now. Just start typing text in your external file. Also, for your nav, is there a reason why you are putting each nav button into a separate cell? I would use a <br/> at the end of each nav button instead of separate cells (it will clean up the code some and you wont have to use the colspan attribute). But I think your main problem is opening and closing too many html, body, head tags in your code. That should clear some of it up. Fix that and then I will look at it again when I get a chance.

  3. #3
    freaking website
    Macman's Avatar
    Member Since
    Oct 30, 2004
    Location
    San Antonio, Texas
    Posts
    4,374
    Specs:
    PowerMac G4 Cube 450mhz 832mb
    ok, heres your problem, I see your table widths are in percentages, you need to change it to an actual number in pixels, ie, the width + 5 or so pixels wider than a button or that table content.

  4. #4
    freaking website
    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    okay, ill be getting this all sorted out in a little while, thank you very much!

    until then, i must go study for and pass a test!

    and maybe cook the gf breakfast too becasue she's mad

    -chris
    MoTM honor roll...
    when?
    i dont remember

  5. #5
    freaking website
    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    Quote Originally Posted by vtupser
    One issue you might be having in your code is that when you are "including" external files that are HTML files, leave off any tags that open and close the html, body, and head. You have opened and closed html a bunch of times so it is screwing with the browser right now. Just start typing text in your external file. Also, for your nav, is there a reason why you are putting each nav button into a separate cell? I would use a <br/> at the end of each nav button instead of separate cells (it will clean up the code some and you wont have to use the colspan attribute). But I think your main problem is opening and closing too many html, body, head tags in your code. That should clear some of it up. Fix that and then I will look at it again when I get a chance.
    oh...so you mean when i do my <?php require stuff that the website that i am 'linking' to i should not have any <head> or <body> <meta> etc at all?
    -chris
    MoTM honor roll...
    when?
    i dont remember

  6. #6
    vtupser
    Guest
    That is correct, just treat it like a regular text file, but you can still put tags in there for like tables, images, links, etc.

  7. #7
    freaking website
    Macman's Avatar
    Member Since
    Oct 30, 2004
    Location
    San Antonio, Texas
    Posts
    4,374
    Specs:
    PowerMac G4 Cube 450mhz 832mb
    yes, but the shifting of the page is caused by the table widths as percentages as I mentioned above.

  8. #8
    freaking website
    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    macman - im changing everything over to exact sizes instead of percentages in the tables...at first i thought percentages would be good, but that idea failed brutally



    whenever iset up the code <?php require ("/announcements.html"); ?> (whatever was mentioned to me earlier that is similar to that code) it can not find the page...i end up having to put http : // www. bryantplayers. com / announcements . html (minus spaces) in order for the file to be found

    thank you all for the great and prompt help folks!!!!

    -chris
    MoTM honor roll...
    when?
    i dont remember

  9. #9
    freaking website
    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    ill just double post this:

    also now my nav bar buttons arent being found...the files are all in the correct place, i have a feeling it is the fact that it is linked through /buttons/(buttonname.jpg) that is causing the problem

    -chris
    MoTM honor roll...
    when?
    i dont remember

  10. #10
    freaking website
    Murlyn's Avatar
    Member Since
    Jun 11, 2003
    Location
    Mount Vernon, WA
    Posts
    4,915
    Specs:
    MacBook Pro 2.6 GHz Core 2 Duo 4GB RAM OS 10.5.2
    when you do an include it's looking from server root, not web root, so you'll need to do this:

    require_once('../buttons/buttonname.jpg');

    instead of:

    require_once('/buttons/buttonname.jpg');

    and same with your first example.

  11. #11
    freaking website
    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    update...fixed most things and i think i am almost done with this crap!!!! (too bad the person who is suposed to be running the website doesnt do his job and i am doing it for him)

    so, when deleting all the body and meta tags and what not from the pages, what do i do about the javascript stuff in the header that preloads images?

    once again, thanks for the help!! beers all around!!
    -chris
    MoTM honor roll...
    when?
    i dont remember

  12. #12
    freaking website
    Murlyn's Avatar
    Member Since
    Jun 11, 2003
    Location
    Mount Vernon, WA
    Posts
    4,915
    Specs:
    MacBook Pro 2.6 GHz Core 2 Duo 4GB RAM OS 10.5.2
    You should have one header file that has all that stuff (js, meta, etc) in it, and then include the appropriate "body" pages after that. If you want to control the meta tags on a per page basis, do something like this:

    <?php
    $page['title'] = 'This is the title of the page';
    $page['meta_keywords'] = 'keywords go here';
    require_once('header.inc.php');
    ?>
    Insert body of page here.


    In the header.inc.php file have this:


    <html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
    <meta name="keywords" content="<?=$page['keywords']?>">
    <title><?=$page['title']?></title>
    javascript scripts
    css includes
    </head>
    <body>

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Freaking out Please help!
    By whatdaproblemis in forum Running Windows (or anything else) on your Mac
    Replies: 6
    Last Post: 02-12-2011, 12:51 PM
  2. I am so freaking new
    By ShuaTribe in forum Switcher Hangout
    Replies: 2
    Last Post: 04-30-2010, 06:45 PM
  3. Freaking out, desperately need help!
    By Someguy2055 in forum Apple Notebooks
    Replies: 2
    Last Post: 01-14-2010, 02:39 PM
  4. iPhone freaking out
    By derekblock in forum iPhone Hardware and Accessories
    Replies: 3
    Last Post: 03-10-2009, 06:57 AM
  5. Airport Freaking Out HELP!!!
    By friday9x in forum Apple Notebooks
    Replies: 1
    Last Post: 03-03-2007, 03:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •