Results 1 to 5 of 5
  1. #1


    Member Since
    Feb 25, 2015
    Location
    Budapest, Hungary
    Posts
    147
    Specs:
    Late 2014 Mac Mini (Base Model, Sierra); iPad Air 1 (iOS 10.2); iPhone 7 (iOS 10.2)
    "Cannot Verify Server Identity" - could "Continue" on Mac and iPad but not iPhone 7
    As it says, got this error yesterday from one of the university email address where I work. On both my Mac and iPad, when this happened in Mail, it gave this message with a "Cancel" or "Continue" option, so i could just say continue and get my university emails.

    However, on iPhone Mail, it says the message above, but only has "Details" and "Cancel" as the options. "Details just does that - gives details, tells me the certificate is not trusted, and gives a button for "More Details", which says a whole bunch of stuff, but no other choices to make.

    Also, after trying three times to confirm the address I guess, I get a message that "Unable to verify SSL server imap.***.***" Then it tells me to confirm my settings and that the thing does SSL, which of course it does.

    So, what can I do? I can still check on my Mac and iPad, but obviously, I'd like to be able to check my university emails on my iPhone as well. Thoughts? Other than wipe out the account and recreate it on the iPhone (which maybe I will do if I don't get any other ideas).

  2. #2

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,790
    What version of iOS is running on the iPad? And what version OS X on the Mac? Since the iPhone is a 7, it obviously has to be iOS 10. If the others are not up-to-date, then it may be a problem specific to iOS 10. Also, are you on wi-fi with the iPhone, or just using cellular data service? Make sure you try it on wi-fi if you haven't. You should also check your Mail settings on the iPhone to make sure they are set identical to what you have on the iPad.

    Just to be clear... you are using the Mail app on all these devices, and not a web browser?

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    ------
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    ------
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

  3. #3


    Member Since
    Feb 25, 2015
    Location
    Budapest, Hungary
    Posts
    147
    Specs:
    Late 2014 Mac Mini (Base Model, Sierra); iPad Air 1 (iOS 10.2); iPhone 7 (iOS 10.2)
    Quote Originally Posted by Lifeisabeach View Post
    What version of iOS is running on the iPad? And what version OS X on the Mac? Since the iPhone is a 7, it obviously has to be iOS 10. If the others are not up-to-date, then it may be a problem specific to iOS 10. Also, are you on wi-fi with the iPhone, or just using cellular data service? Make sure you try it on wi-fi if you haven't. You should also check your Mail settings on the iPhone to make sure they are set identical to what you have on the iPad.

    Just to be clear... you are using the Mail app on all these devices, and not a web browser?
    Hmm...thought that was visible (I have specs under my user info on the left panel). Anyway, everything is latest possible. Mac is running Sierra latest, iPad Air is running latest 10, same for iPhone. And yes, I'm using only the Mail app for this email address which is having the problems.

    P.S. - just tried turning on and off SSL in the Advanced settings and...it worked? So far. Strange.

  4. #4

    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,790
    Quote Originally Posted by Mencelus View Post
    Hmm...thought that was visible (I have specs under my user info on the left panel).
    Ooops... my bad.

    Anyway, everything is latest possible. Mac is running Sierra latest, iPad Air is running latest 10, same for iPhone. And yes, I'm using only the Mail app for this email address which is having the problems.

    P.S. - just tried turning on and off SSL in the Advanced settings and...it worked? So far. Strange.
    Glad that worked, Easier than what would have been the next suggestion, which would have been to delete all the settings and start over from scratch.

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    ------
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    ------
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

  5. #5


    Member Since
    Feb 25, 2015
    Location
    Budapest, Hungary
    Posts
    147
    Specs:
    Late 2014 Mac Mini (Base Model, Sierra); iPad Air 1 (iOS 10.2); iPhone 7 (iOS 10.2)
    Quote Originally Posted by Lifeisabeach View Post
    Glad that worked, Easier than what would have been the next suggestion, which would have been to delete all the settings and start over from scratch.
    Yeah, that is what I wanted to avoid. In this case, very simple "fix", though I don't know why it worked.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Moving "iPhone, iPad, iPod" category below "Apple Hardware."
    By bbnck in forum Community Suggestions and Feedback
    Replies: 1
    Last Post: 10-29-2016, 09:20 PM
  2. "Unable to verify identity of website" message
    By HeyChason in forum OS X - Operating System
    Replies: 4
    Last Post: 10-09-2014, 08:14 PM
  3. Performed "verify" and "repair" on external...need help...
    By osker246 in forum OS X - Operating System
    Replies: 9
    Last Post: 06-26-2013, 03:50 AM
  4. Replies: 8
    Last Post: 01-21-2013, 03:44 PM
  5. Help! Sites "can't verify identity"
    By rsherid in forum Internet, Networking, and Wireless
    Replies: 1
    Last Post: 01-30-2012, 09:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •