Results 1 to 4 of 4
  1. #1
    Loss of data after Automator Rsync Workflow

    Member Since
    Sep 27, 2013
    Location
    Germany
    Posts
    25
    Specs:
    Late 2013 imac 3.5 GHz i7 16GB GTX 780M 3TB Fusion Drive 10.9.2
    Loss of data after Automator Rsync Workflow
    After reading through this:

    Geek Stuff - Synchronize two folders on a Mac with Automator and Rsync - Branko Jevti?'s Piece Of Web

    I created a test folder with just 3 items in it plus the same on an external drive and very carefully following each step I ran the Workflow.

    It was taking too long so I stopped it to find that it was deleting data from the external drive itself and not just the specified folder. It deleted a lot very quickly but I managed to retrieve it from other drives and everything seems ok. Although various seemingly random files on both drives are showing a date and time modified as of today when the workflow was running.

    I'm new to mac and this was my first time using Automator and rsync so please help me to understand what went wrong.

    Thanks in advance.

    Graham

  2. #2
    Loss of data after Automator Rsync Workflow
    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,398
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    I'm guessing that you accidentally mistyped a command somewhere along the lines which caused this (the smallest of tweaks can cause the largest of pains). Copy and paste any and all commands you entered into the workflow here and we'll see what we find.
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  3. #3
    Loss of data after Automator Rsync Workflow

    Member Since
    Sep 27, 2013
    Location
    Germany
    Posts
    25
    Specs:
    Late 2013 imac 3.5 GHz i7 16GB GTX 780M 3TB Fusion Drive 10.9.2
    Thanks for your response vansmith.

    here's a screenshot of the Workflow

    Graham
    Attached Images Attached Images

  4. #4
    Loss of data after Automator Rsync Workflow

    Member Since
    Sep 27, 2013
    Location
    Germany
    Posts
    25
    Specs:
    Late 2013 imac 3.5 GHz i7 16GB GTX 780M 3TB Fusion Drive 10.9.2
    I forgot to add that I tried this earlier and it worked fine.

    I used the command line from this video. See at 3.50

    Backup using rsync - YouTube

    then dragged and dropped my test folder (see my original post) followed by my external from the Desktop. No problems.

    Sorry about the massive screenshot above, my first here. I'd better check out how to do this better.


    Graham

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Request for Workflow (Automator)
    By TomBot in forum OS X - Apps and Games
    Replies: 3
    Last Post: 07-11-2012, 10:20 PM
  2. Automator workflow help
    By bassguy86 in forum OS X - Operating System
    Replies: 0
    Last Post: 08-31-2011, 03:20 AM
  3. Automator Workflow?
    By slugzzz in forum OS X - Apps and Games
    Replies: 0
    Last Post: 02-20-2008, 02:49 PM
  4. Automator Workflow
    By shahvikram123 in forum OS X - Operating System
    Replies: 0
    Last Post: 07-21-2007, 12:51 PM
  5. Automator Workflow
    By rs2sensen in forum OS X - Operating System
    Replies: 0
    Last Post: 10-13-2005, 07:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •