Results 1 to 3 of 3
  1. #1
    Wifi Issues in Windows 7 on rMBP
    khcrazy10's Avatar
    Member Since
    Apr 04, 2013
    Location
    Canada
    Posts
    32
    Specs:
    Macbook Pro Retina 15" 2.7 GHz Intel Core i7 with 16 GB DDR3 Ram running OS X 10.8.4 Mountain Lion
    Wifi Issues in Windows 7 on rMBP
    Ok so I have the 15" Retina Macbook Pro 2.7 GHz with the 802.11 wireless N card. I dual booted Windows 7 Professional OEM copy on it yesterday and I've noticed some pretty slow speeds on my speed test. Right now my family is paying for a 50mb/s download speed and 3mb/s upload speed.

    On the speed test (provided through my ISP's site and the only thing they'll take seriously if I call in about speed issues), the upload speed comes back fine but the download speed is cut down to a speed between 10 and 20mb/s. Lowest speed readout has been 2mb/s this morning.

    The mac side shows a perfect speed test and I tried tethering my Android phone on the windows side to share its Wifi card and it comes back at the phone's max speed ability on the speed test.

    Is there anything I can do to fix the speed on the windows side as I will be using it for my main school system while the mac side is there for audio and video work? Maybe a driver or something? I have the latest version of Boot Camp installed.

    Thank you!

  2. #2
    Wifi Issues in Windows 7 on rMBP
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,183
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    You should be receiving the same download and upload speeds while in OS X and Windows 7. The only suggestions I have is to make sure you have everything setup correctly in Windows 7 and that you're using the latest Windows driver for your airport card. Use the control panel Boot Camp update utility to make sure you have the latest version of Boot Camp installed for Windows. Boot Camp updates may contain updated drivers.

  3. #3
    Wifi Issues in Windows 7 on rMBP
    khcrazy10's Avatar
    Member Since
    Apr 04, 2013
    Location
    Canada
    Posts
    32
    Specs:
    Macbook Pro Retina 15" 2.7 GHz Intel Core i7 with 16 GB DDR3 Ram running OS X 10.8.4 Mountain Lion
    Ok I tried reinstalling the drivers and it improved the speed... it wasn't until today that I got full network speed on the windows side though. It's possible it could have been my ISP since there's people in my house who have noticed a speed drop on SOME devices but not others but I'm not entirely sure. I'm curious as to why the mac side wouldn't be phased if that's the case.

    Anyhow... it's magically working now after having shut it off and turned it back on a few times due to normal shutdown and startup. So yeah.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 13" 2013 rMBP: video/audio issues
    By Mikes88 in forum Apple Notebooks
    Replies: 2
    Last Post: 01-12-2014, 11:34 PM
  2. Windows 8 on rMBP Haswell
    By nhl1 in forum Running Windows (or anything else) on your Mac
    Replies: 14
    Last Post: 11-07-2013, 01:32 AM
  3. New base rMBP vs top rMBP Mid 2012
    By gphxguru in forum Apple Notebooks
    Replies: 2
    Last Post: 10-26-2013, 07:33 AM
  4. Using Apple USB Superdrive to install Windows 7 on rMBP
    By khcrazy10 in forum Running Windows (or anything else) on your Mac
    Replies: 2
    Last Post: 07-07-2013, 07:36 PM
  5. rMBP with temperature issues plus others
    By dede94 in forum Apple Notebooks
    Replies: 4
    Last Post: 02-04-2013, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •