Results 1 to 4 of 4
  1. #1
    got windows 7 ultimate working, but after few days working, now black screen

    Member Since
    Jul 07, 2010
    Posts
    1
    Question got windows 7 ultimate working, but after few days working, now black screen
    hey,

    after a lot of trouble I got windows 7 ultimate working on my iMac 27" 3.06 ghz jan. 2010 (bootcamp 3.1) with ATI videocard. I used the usb stick trick (with master boot) during installation, and I got it working. So I moved on, installed some small programs. 2 days later I wanted to use my windows 'side' again, however when I start it, i only get a black screen. And even after a reset i don't even get a question to startup in safemode or something. Just a black screen. Not an intro picture (as I got at the black screens during the installation).

    i tried removing atikmdag.sys but didn't work (thought it was a driver issue again, and hoped to solve it this way).

    I really thought i had it working. i installed all the updates, all drivers, everything worked, but now I only get a stupid black screen. It is really frustrating.

    Hope anyone could help me.

    Greetz,

    Barbet

    PS the installation was via a burned cd from a friend, i installed it for my work with a company license. However the cd can be a downloaded version (which I am 100% sure is a good version).

  2. #2
    got windows 7 ultimate working, but after few days working, now black screen
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,176
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    I'm not sure I understand what it is you did to install Win 7? Why did you have to use a USB stick? You go on to say that you have a CD and used your company license - wasn't the CD or DVD bootable?

    It sounds like the Win 7 boot sector has been damaged. The way to repair it is by using a Windows 7 install DVD and booting your iMac with it. Hold down the "Option" key after you hear the chime and select the Windows 7 DVD as the boot device. When the Windows 7 disk comes up, select repair. See the following Microsoft Article.

    Before doing anything make certain you have a backup of your Snow Leopard installation. Time Machine, SuperDuper, or Carbon Copy Cloner can be used to make the backup.

    Regards.

  3. #3
    got windows 7 ultimate working, but after few days working, now black screen
    mrplow's Avatar
    Member Since
    Oct 01, 2007
    Location
    UK
    Posts
    6,759
    Specs:
    27" iMac i7 (2011) 10.10, iPhone6, iPad Air 2, AppleTV2
    chscag:
    I suspect the USB drive was used as per these instructions; Boot Camp: iMac (27-inch, Late 2009) displays a black screen during installation of Windows 7 using Boot Camp
    It's the method I used on my iMac and it works fine.
    External hard disk acquisition addict - but admitting the problem is the first step to a robust backup

    Please use the reputation system if you think you've been helped - top right of this post

  4. #4
    got windows 7 ultimate working, but after few days working, now black screen
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,176
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    Thanks for posting the Link. I had forgotten about the driver problem and the black screen. We'll see if the OP was able to repair his Win 7 installation using the MS repair method.

    Regards.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Monitor not working, stays black when awake from sleep
    By Harrison1974 in forum Apple Desktops
    Replies: 2
    Last Post: 09-14-2012, 01:58 PM
  2. Intuit And Apple Working To Try And Get Quicken 2007 Working On Lion
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 2
    Last Post: 06-17-2011, 10:53 AM
  3. MBP screen not working with windows(bootcamp)
    By sintar in forum Apple Notebooks
    Replies: 0
    Last Post: 12-10-2010, 12:52 PM
  4. DSL suddenly not working on Mac, Working fine on Windows
    By Sr-ultimate in forum OS X - Operating System
    Replies: 1
    Last Post: 02-15-2009, 06:40 PM
  5. Replies: 17
    Last Post: 08-18-2008, 05:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •