Results 1 to 5 of 5
  1. #1
    Epson R800 problems

    Member Since
    Jan 17, 2007
    Location
    Ireland
    Posts
    7
    Specs:
    G5 Powermac 2x1.8 Ghz, 80Gb internal HD, 1.25Gb ram
    Unhappy Epson R800 problems
    Have just installed OS10.4 and nowfind that my mac cannot find my Epson R800 printer which was working perfectly on OS10.3 on both firewire and USB. It now tells me there it cannot find the printer and when I check in the print monitor I can see the printer in USB but not in Firewire.

    When trying to print in USB I get the same problem.. The USB works perfectly on my PC laptop.

    I have downloaded the latest drivers from the Epson site and reinstalled the printer drivers from the apple disc but still no joy. Can anyone shed some light and helop get my printer working.

    Thanks

  2. #2
    Epson R800 problems
    Odin_aa's Avatar
    Member Since
    Jul 07, 2005
    Location
    North Boston, NY
    Posts
    604
    Specs:
    PowerMac G5 2.3 ghz 6.5 GB ram 20" cinema display ..15" Macbook Pro 2.33 Core 2 Duo 2 Gig RAM
    Have you tried anything else in that Firewire port?
    http://www.lightcafe.net

    New servers, much faster than before

  3. #3
    Epson R800 problems

    Member Since
    Jan 17, 2007
    Location
    Ireland
    Posts
    7
    Specs:
    G5 Powermac 2x1.8 Ghz, 80Gb internal HD, 1.25Gb ram
    Thanks for the reply. The firewire port is operating ok as I have an external firewire HD and it is operating fine. I have disconnected the HD and connected the printer directly to the firewire (bypassing the firewire daisy chain) and still no joy. The USB port is not printing either yet the USB prints perfectly on a PC laptop.

  4. #4
    MacHeadCase
    Guest
    The driver should be in your system somewhere (see this Apple webpage, Mac OS X Tiger included Epson drivers).

    Did you try adding it to your printer list? Check this Apple webpage out Printing & Faxing.

    If those troubleshooting tricks don't bring any results, you might want to download Gutenprint.

  5. #5
    Epson R800 problems
    Sa!!yz~Rage's Avatar
    Member Since
    May 09, 2007
    Location
    Ontario
    Posts
    27
    Specs:
    G4-933, PB-1.25, TiBook-1Ghz
    I had a similar problem with the 4800 I have. I had to delete everything that was Epson and do a clean install of the drivers. That worked for me. Also repaired permissions after the cleaning.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Epson R800 driver - won't work on iMac/
    By Kipling in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 09-04-2010, 02:46 PM
  2. Epson Printing Problems
    By flauri in forum Other Hardware and Peripherals
    Replies: 0
    Last Post: 01-10-2010, 04:01 PM
  3. Epson printer problems
    By Sur3Mac in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 09-05-2009, 10:04 AM
  4. Epson R800 problems
    By David Mackay in forum Apple Desktops
    Replies: 3
    Last Post: 05-04-2007, 06:04 AM
  5. Problems with Epson Printer
    By HerbertS in forum OS X - Operating System
    Replies: 1
    Last Post: 01-18-2005, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •