Can anyone help with this - I have an emac and an external lacie mini ethernet drive - the mac recognises the drive but it is telling me that there are 0 files on it (when there are hundreds). It just won't index it. The drive is connected to another mac which can see all the files perfectly well. It is driving me nuts.

Please help!

thanks

Update: Thinking about it, this happened after a power cut, my emac can see my networked lacie drive, but it says there are 0 items in it (there are hundreds). The other mac connected to it has no problem viewing the files, and I can see them if I log onto it over the net.

When I try to index the drive I get a long string of messages like this:

error Jul 5 09:08:41 afpd cnid_update: (1) Unable to update CNID 162155:.FBCLockFolder: Invalid argument
error Jul 5 09:08:41 afpd cnid_lookup: Unable to get CNID did 0x2, name .FBCLockFolder: DB_SECONDARY_BAD: Secondary index inconsistent with primary
error Jul 5 09:08:41 afpd cnid_update: Unable to delete CNID 162156: DB_SECONDARY_BAD: Secondary index inconsistent with primary
error Jul 5 09:08:41 afpd cnid_update: (1) Unable to update CNID 162156:.FBCLockFolder: Invalid argument
error Jul 5 09:08:41 afpd cnid_lookup: Unable to get CNID did 0x2, name .FBCLockFolder: DB_SECONDARY_BAD: Secondary index inconsistent with primary

I need these files desperately - please help!

I am running OS X 10.3.9

Please ask any other questions that you need to know, I am a bit dense so please write in not-too technical language!

Thanks