Hi,

during the progress of backing up an external WD MyBook connected to a Windows Laptop running MacDrive the PC crashed leaving my disk unmountable.
The disk, 1TB in size with two partitons, doesn't mount on my mac. My mac is a very old PowerMac (still waiting for Apple to build a new MacPro )

I checked the disk with pdisk and testdisk (TestDisk Download - CGSecurity).


pdisk shows for my disk:

Code:
Partition map (with 512 byte blocks) on '/dev/rdisk3'
 #:                type name       length   base       ( size )
 1: Apple_partition_map Apple          63 @ 1         
 2:          Apple_Free Extra      262144 @ 64         (128.0M)
 3:           Apple_HFS p1     1073741824 @ 262208     (512.0G)
 4:          Apple_Free Extra   879521136 @ 1074004032 (419.4G)

Device block size=512, Number of Blocks=1953525168 (931.5G)
DeviceType=0x0, DeviceId=0x0
I believe this is good news: there are partitions my mac just doesnt recognize.
Partition #3 is my lost HFS partition; #4 was used for a truecrypt volume of which I have a backup. Maybe there should be a driver somewhere in #2?


testdisks analyze shows:
Code:
    Disk /dev/disk3 - 1000 GB / 931 GiB - CHS 1953525168 1 1                                                                           
    Current partition structure:
         Partition                  Start        End    Size in sectors
                                                                                                                                       
     1 P partition_map                  1         63         63
     2 P Free                          64     262207     262144
     3 P HFS                       262208 1074004031 1073741824
     3 P HFS                       262208 1074004031 1073741824   
     4 P Free                  1074004032 1953525167  879521136
Question: Why is partition 3 listed two times?

testdisk from menu "Advanced" (Partition table gets recognized as Mac. Fine):

Code:
    Disk /dev/disk3 - 1000 GB / 931 GiB - CHS 1953525168 1 1       
                                                                                                                                   
         Partition                  Start        End    Size in sectors
    > 1 P partition_map                  1         63         63
      2 P Free                          64     262207     262144
      3 P HFS                       262208 1074004031 1073741824
      4 P Free                  1074004032 1953525167  879521136
As said, partition 4 is listed as free, but there is encrypted data. But I do have a backup of these, but only partial for partition three.


Selecting part#3, then superblock gives

Code:
    Disk /dev/disk3 - 1000 GB / 931 GiB - CHS 1953525168 1 1
         Partition                  Start        End    Size in sectors
     3 P HFS                       262208 1074004031 1073741824                                         
                                                                                                                                       
    Volume header
    Bad
                                                                                                                                       
    Backup volume header
    Bad

    Sectors are not identical.




I do not know how to proceed from here. Maybe someone can help me with this.


What might be the problem ist: there is no driver in parttion #2. If I could install one, maybe the Mac would recognize the disk? May be initialize the disk with diskutility (should be possible without overwriting any data, just the drivers and parttion map?!) and then run some disk rebuilding tool, eg DiskWarrior?)

Any help appreciated. Thank you in advance!

TH