Results 1 to 5 of 5
  1. #1
    tafika
    Guest
    Question HELP NEEDED: Problem with removing external device
    I've just tried to remove my SD memory card reader from the USB port on my Mac. But for some reason it didn't want to play. The icon is still on my desktop, and the lights are still lit up on the reader. Now, all I can do with the desktop is open up programs from the dock. I can't use any desktop items, or the toolbar at the top. The mouse is on the timer-wheel thing. Basically...

    HELP! Please?!

    Shutting down/restarting has no effect whatsoever, and neither does just removing the reader. I'm still left with a desktop I can't use, and an annoying colour wheel.

    What can I do to get things back to normal?

    Any help is very much appreciated.
    Thanks in advance.

  2. #2
    Aarow
    Guest
    Did you try to cmd+click>eject it?I know this sounds stupid, but I didn't know how to do this until a few days ago... :headphone

  3. #3
    HELP NEEDED: Problem with removing external device
    coach_z's Avatar
    Member Since
    Jul 23, 2004
    Location
    North NJ
    Posts
    3,169
    Specs:
    i dont have no mac's
    did you unmount it first? or did you just unplug?
    -chris
    MoTM honor roll...
    when?
    i dont remember

  4. #4
    HELP NEEDED: Problem with removing external device
    rs2sensen's Avatar
    Member Since
    Mar 20, 2005
    Location
    Michigan, USA
    Posts
    1,416
    Specs:
    1.67 Ghz 17" PB w/1 GB Ram; 400 MHz PM G4, 366Mhz iBook Firewire, Nano 4GB Black
    try hard drive:applications:utilities:disk utility...and repair your disk permissions. if you can't get to this, try booting to the OS X installation disk. this also has disk utility on it, and can be ran from the bar up at the top of it.

  5. #5
    tafika
    Guest
    Yes I did right click, but I didn't even get a menu up, I couldn't use anything other than the dock.

    Yes I did unmount it before unplugging it. That's what caused the problem in the first place.

    As for disk permissions, I did not think of that one.

    Doesn't matter now anyway. I was stuck with it like that for 3 hours. I then leave the computer on over night, come back, and everything is fine again.

    Odd, very odd.
    Thanks anyways folks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Transferring data to external device
    By TenerifeMac in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 09-07-2014, 11:33 AM
  2. external hardware device for MacBook?
    By rippersroo in forum Apple Notebooks
    Replies: 6
    Last Post: 02-05-2012, 03:09 AM
  3. (Q) What's a good external capture device?
    By CookieMan in forum Movies and Video
    Replies: 2
    Last Post: 12-05-2011, 07:57 AM
  4. External Device Network Issue
    By nikod in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 10-20-2009, 02:32 AM
  5. Removing Apple Mobile Device Support
    By sburnham in forum Running Windows (or anything else) on your Mac
    Replies: 0
    Last Post: 10-01-2009, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •