Results 1 to 3 of 3
  1. #1
    MagSafe bad connection?

    Member Since
    May 06, 2010
    Location
    Earth, In a country
    Posts
    13
    Specs:
    13" MBP 2.4Ghz Intel Core 2 Duo 250GB HD 4GB Ram OS X 10.6.4 IOMega 1TB External HD iPod nano 3g 8GB
    Angry MagSafe bad connection?
    Yet another problem has struck my MacBook Pro 13 in the space of a few months. I bought this computer back in May (I think). Anyway it's one of the new April 2010 ones. But I have had multiple problems with it, first the hard drive died and now the MagSafe won't work.

    So I went to use my computer today to find that the battery was running on reserve power. So I pulled my MagSafe off my shelf and plugged it in (As you would ) and it started to charge normal at first, but then I wondered why it said again that it was running on reserves. So I checked that it was plugged in the wall outlet all the way which it was, and then moved on to the power brick - again same thing, it was all connected. I go over and check my computer and yet again everything is connected as it normally would be.

    So I wondered why there was no light on the MagSafe and started Google-ing the problem, but there were no solutions to my problem (This was in the space of 30 mins by the way). So I started to do some "diagnostics" of my own, and in a few minutes I figured out that when I hold my MacBook vertically with the I/O facing upwards and the SuperDrive facing downwards it starts to charge as normal, then when I put it in normal position it stops charging.

    Do you think this is a problem with the MacBook or the MagSafe?

    I have tried cleaning the connections, trying different outlets, but still no luck.

    Google wasn't giving me any helpful answers so I thought I would talk to the friendly guys on the forum.

    Thanks!

  2. #2
    MagSafe bad connection?
    TattooedMac's Avatar
    Member Since
    May 19, 2009
    Location
    Waiting for a mate . . .
    Posts
    8,379
    Specs:
    21" iMac 2.9Ghz 16GB RAM & 13"MBP 2.9Ghz i7 8GB RAM 10.10.3, iPhone5 & iPad Air 2 iOS 8.3, ATV3
    Repair permission via Disk Utility and then log out then back in and see what happens. I have noticed sometime after my MBP 13" is plugged in for a while that i get the *orange* light on the magsafe. With a reboot all seems well and light goes to green ...

    ?? worth a try anyways

    Cheers
    Dont forget to use the Reputation System if someone has helped you out !!!
    Arguing with a zealot is only slightly easier than tunneling through a mountain with your forehead!!!!!
    MoTM ☆☆☆

  3. #3
    MagSafe bad connection?
    chas_m's Avatar
    Member Since
    Jan 22, 2010
    Location
    Victoria, BC
    Posts
    18,970
    Specs:
    Mid-2012 MBP (16GB, 1TB HD), Monoprice 24-inch second monitor, iPhone 5s 32GB, iPad Air 2 64GB
    It sounds like there is still some obstruction in either the receptacle or in the "teeth" of the magsafe connector that is causing a short. Get a magnifying glass and check those two areas carefully.

    I've cleared out tiny bits of metal from magsafe receptacles several times that "miraculously" made them start working again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad keyboard connection
    By durkinjt in forum Switcher Hangout
    Replies: 4
    Last Post: 04-29-2013, 08:06 PM
  2. Bad Skype connection
    By moonandtree in forum OS X - Apps and Games
    Replies: 2
    Last Post: 02-10-2011, 03:17 AM
  3. Magsafe/Battery Problem: No Magsafe light, Battery not charging
    By empty_noise in forum Apple Notebooks
    Replies: 2
    Last Post: 07-03-2010, 08:57 AM
  4. bad connection, europe
    By rpagliari in forum Apple Notebooks
    Replies: 2
    Last Post: 06-30-2010, 01:21 PM
  5. cleaning magsafe connection? (mantinance)
    By Mac Dre in forum Apple Notebooks
    Replies: 4
    Last Post: 09-12-2007, 10:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •