Results 1 to 4 of 4

Thread: Mouse problems?

  1. #1
    Mouse problems?

    Member Since
    Jan 08, 2010
    Location
    Parkston, SD
    Posts
    64
    Specs:
    See Signature.
    Mouse problems?
    I have an original M4848 "Hockey Puck" mouse that I have kinda become attached to. I carry it between my desk @ home and work because I absolutely hate the trackpads on my work computer. I opened my case this afternoon and found that the button was not working.(It looks like the sensor for the click feature got shifted back into the mouse itself) Everything else works except the button. I'd really hate to throw it away, son are there any tips on how to fix this, or at least take it apart and see if I can fix it?
    Zach H.
    PowerMac G4 AGP graphics, Mac OSX 10.4.11, 512 MB RAM, 10GB HD, 802.11g network card, 400 MHz PowerPC processor, 500GB Western Digital External HD hooked up on FW400

  2. #2
    Mouse problems?
    Collin Bl's Avatar
    Member Since
    Apr 07, 2009
    Location
    Napier NZ
    Posts
    3,291
    Specs:
    27 iMac i5, MBP 13 & iMac 20, 2TB dual TC, AppleTV, iPh4S
    Google is your friend. Have a hunt here iFixit: Apple Mac, MacBook, iPod, and iPhone Repair Parts

  3. #3
    Mouse problems?

    Member Since
    Jan 08, 2010
    Location
    Parkston, SD
    Posts
    64
    Specs:
    See Signature.
    Thanks. I'll have a look around and report back later.
    Zach H.
    PowerMac G4 AGP graphics, Mac OSX 10.4.11, 512 MB RAM, 10GB HD, 802.11g network card, 400 MHz PowerPC processor, 500GB Western Digital External HD hooked up on FW400

  4. #4
    Mouse problems?

    Member Since
    Jan 08, 2010
    Location
    Parkston, SD
    Posts
    64
    Specs:
    See Signature.
    I took a look at it, but most of the mouse stuff was current-gen mighty mouse. I might go to best buy and pick up a wireless mighty mouse later this week. @ Collin Bl: Thanks for the site. Might be able to use it later.
    Zach H.
    PowerMac G4 AGP graphics, Mac OSX 10.4.11, 512 MB RAM, 10GB HD, 802.11g network card, 400 MHz PowerPC processor, 500GB Western Digital External HD hooked up on FW400

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mouse problems.
    By Photo in forum Switcher Hangout
    Replies: 5
    Last Post: 01-15-2013, 09:00 AM
  2. mouse problems
    By houndsound in forum Apple Desktops
    Replies: 7
    Last Post: 03-19-2012, 07:30 PM
  3. Mouse problems
    By Peter Sarl in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 08-10-2008, 07:10 PM
  4. problems with mouse
    By Jayfaas in forum Apple Desktops
    Replies: 1
    Last Post: 07-27-2008, 07:46 PM
  5. Mouse problems
    By mary18 in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 03-24-2007, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •