Results 1 to 3 of 3
  1. #1
    Having trouble installing flashed sapphire 487

    Member Since
    Nov 05, 2009
    Posts
    10
    Unhappy Having trouble installing flashed sapphire 487
    EDIT: sapphire 4870

    Hi, i recently bought a Sapphire Radeon HD 4870 512M GDDR5 PCI-E DUAL DVI-I/TVO SKU# 21133-00 S/N 180825044742 flashed with mac firmware.

    The instructions said to take out my existing card put the sapphire in slot 1, then boot up and install drivers.

    So i took my Nvidia 7300 GT card out of slot 1 and put in the 4870, then started up. I get the grey start up screen with the apple in low resolution for about 8 sec, then the screen just goes blank.

    What am i doing wrong?... do i need to keep the Nvidia 7300 GT in slot 2, then boot up connected to that first?

    Im really frustrated. Could someone please help me? It would be greatly appreciated.

    Thanks.

  2. #2
    Having trouble installing flashed sapphire 487
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,282
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    Did the Sapphire card come already flashed for use in a Mac or did you update and flash the new firmware yourself? The reason I ask is that it sounds like the card is not compatible - possibly because of a bad firmware flash update. (The symptoms you describe point to a graphics card problem.)

    Flashing a PC graphics card with Mac firmware so that it can be used in a Mac is iffy at best. Sometimes it works and sometimes it doesn't.

    Also it would help if you could let us know which Mac (model and year) you're installing the Sapphire in.

    Regards.

  3. #3
    Having trouble installing flashed sapphire 487

    Member Since
    Nov 05, 2009
    Posts
    10
    Im running a Mac Pro 1,1

    The card was pre flashed from a guy that was using is successfully in a Mac Pro 1,1. I've never installed a graphics card, so i'm thinking the problem may lie on me end.

    Right now, im running with the 4780 card in slot one, and the Nvidia 7300 in slot 3. Do i need to install drivers, then re boot connected to the 4870? If so, where do i get the drivers?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rumor: Apple to feature sapphire crystal touch home button on 'iPhone 5S'
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 0
    Last Post: 05-14-2013, 10:10 AM
  2. trouble installing OS X
    By DaBeavs541 in forum Switcher Hangout
    Replies: 3
    Last Post: 08-11-2009, 11:12 PM
  3. screen flashed solid black
    By kouroshl in forum Apple Notebooks
    Replies: 0
    Last Post: 02-23-2009, 04:21 PM
  4. Trouble Installing on my G5
    By CaptainRitalin in forum OS X - Operating System
    Replies: 1
    Last Post: 01-15-2008, 06:02 PM
  5. Trouble Installing
    By mac_noobie in forum Switcher Hangout
    Replies: 1
    Last Post: 08-22-2004, 09:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •