Results 1 to 5 of 5
  1. #1
    External drive mounts but is inaccessible

    Member Since
    Jun 03, 2008
    Posts
    22
    External drive mounts but is inaccessible
    My external firewire (Rocstor) hard drive is inaccessible, but it still "mounts"!!
    I can see it in my disk utilities, I can even search the files that are on the drive! But when I select a file it is an alias that I can't access. I tried clicking "repair disk" and it said "No repairs necessary"
    The computer sees it but I cannot, and there is no way to access it.
    This problem started when I selected "no access" (in get info) on a folder while something was writing to it. Then it said "read and write" but it was greyed out. I'm not sure if that's exactly what happened, It was really just a slip of my finger and then when I restarted, it was gone.
    PLEASE help! This will be absolutely devastating if I lose this data. Is there any kind of maintenence that I can do? I don't know about this stuff.

  2. #2
    External drive mounts but is inaccessible
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,293
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    I'm not sure what happened either. I suspect the permissions were changed on the drive and now you're locked out.

    Try this: With the drive mounted, reboot your machine and log back on as the ROOT user. Follow the directions in this Apple KB article which explains how:
    Link

    Once logged on as ROOT user and with the system back up, try accessing the files on the external drive. If you still can't, right click on the drive, select get info, click on the small lock to open it if it's closed, and change permissions to read and write.

    You should be able to access your files on the drive once more.

    A note of caution while you're logged on as ROOT user - do not attempt to do anything else. After you're finished, reboot and log back on as yourself.

    Regards.

  3. #3
    External drive mounts but is inaccessible

    Member Since
    Jun 03, 2008
    Posts
    22
    Just to clarify, I can't see the drive at all but the computer can. I can't access it (Cause I can't see it) but disk utility acknowledges that it is plugged in... it also says that it has zero files on it.
    I logged in as the ROOT user and I see the drive perfectly fine, with all the files in tact. It has read and write access, but that doesn't help me. Logged in as a user I cannot access or see the drive, even though the computer recognizes it and the drive sounds normal.

  4. #4
    External drive mounts but is inaccessible

    Member Since
    Jun 03, 2008
    Posts
    22
    Fixed it! Someone recommended going back into the root, where I saw read and write and select details. There was a few more read and write windows, one of which said no access. Changing that fixed it. Thanks!

  5. #5
    External drive mounts but is inaccessible
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,293
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    Quote Originally Posted by krumlin View Post
    Fixed it! Someone recommended going back into the root, where I saw read and write and select details. There was a few more read and write windows, one of which said no access. Changing that fixed it. Thanks!
    Great. Glad to hear you got it fixed, ROOT user to the rescue! Just be careful using the ability to log on as ROOT.

    Regards.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. external hard drive mounts as super/disc drive?
    By nathan549 in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 03-02-2013, 09:16 PM
  2. Replies: 10
    Last Post: 12-19-2011, 01:58 PM
  3. External WD Drive Mounts, But is Alias, No Access
    By tmdowd in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 05-28-2010, 03:03 PM
  4. External HD mounts.. but folders disappear
    By keithwyland in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 11-27-2009, 12:38 AM
  5. External hard drive no longer mounts
    By sputacus in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 06-13-2009, 12:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •