Results 1 to 13 of 13
  1. #1
    Iomega Portable Hard Drive not mounting

    Member Since
    Mar 23, 2009
    Posts
    6
    Iomega Portable Hard Drive not mounting
    hi - i've just bought an Iomega eGo Helium Portable Hard Drive for my Mac OS X 10.4 laptop. It will not mount on the desktop, but is instantly found on my office's windows based computer. i would guess that my laptop is not getting power to the portable hard drive as it is not found, nor does the unit light up (indicating it's active.)
    the laptop's disk preferences indicate that hard drives will mount on the desktop?
    does anyone have any ideas as to how to trouble shoot getting power to a periphial?
    thanks

  2. #2
    Iomega Portable Hard Drive not mounting
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,020
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    G'day and welcome to the forums.

    Sounds like your drive has not been formatted.

    I take it your PowerBook is a PowerPC model (PPC), and these require an external drive be Apple Partition Map set up, even if one partition is selected, and then formatted to Mac OS Extended (Journaled). To be bootable you must connect via Firewire as USB, even USB2 will not boot on most PPC machines.

    Most external casings are mains powered as the drain on your USB port may simply be too demanding.

  3. #3
    Iomega Portable Hard Drive not mounting

    Member Since
    Mar 23, 2009
    Posts
    6
    Iomega hard drive
    Hi Harry - thanks for the input, but, ummm...can you put that into english for me? i'm not that technical. thanks & cheers!
    pat

  4. #4
    Iomega Portable Hard Drive not mounting
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,020
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    Okay connect the external HDD to the PowerBook. How does it connect by Firewire or USB? Go to Utilities and select Disk Utility and se if the external appears. If so select the image, partition and format. The HDD should then appear on the desktop.

    You may well have a problem with the power if it is drawn from the laptop by USB. Keep us posted.

  5. #5
    Iomega Portable Hard Drive not mounting

    Member Since
    Mar 23, 2009
    Posts
    6
    Iomega hard drive
    well, you seem to have hit it square on the head. the drive connects thru a usb. it does not light up, whir, or anything. it's dead. (it does wake up when i connect it to my office's windows pc.)
    my finder preferences shows that hard disks appear on the desktop, and infact my mac hd does appear on the desktop. the hdd does not appear in disk utilities.
    i think that it is a pretty good bet that the usb isn't getting enough power to the hdd, but my question now is how do i get that to happen?

  6. #6
    Iomega Portable Hard Drive not mounting

    Member Since
    Mar 23, 2009
    Posts
    6
    Iomega hard drive
    update:
    Iomega seems to think that the usb's aren't providing enough power. the hdd that i bought does not have a firewire port. they are sending a y-shaped cable to me (free!)
    i'll let you know how this works.

  7. #7
    Iomega Portable Hard Drive not mounting
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,020
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    Pity you never asked beforehand what type of external to get for a laptop ~ assume a G4 model?

    Apple Macs do not work that well on USB, even USB2, and much prefer Firewire which of course is Apple developed. If your cable arrives and does not have connection to mains power you may be no better off.

    You may have to consider a mains powered USB port, and connect through that?

    http://www.nextdaypc.com/main/produc...inid=ND0130014

  8. #8
    Iomega Portable Hard Drive not mounting

    Member Since
    Mar 23, 2009
    Posts
    6
    iomega hard drive
    yeah, it would have been nice if i had asked before, but i found this iomega drive thru macworld. who knew? and yes, it is a G4. i was hoping to find something without needing mains power. what's the sense of having a wireless laptop if you have to be tied down? if the y-shaped cable does not work, i'll probably try to find a firewire model. thanks for the link, though.

  9. #9
    Iomega Portable Hard Drive not mounting
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,020
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    Even with the wireless laptop running nicely, don't think the battery would stand up to running a USB external drive from the USB port. Same as installing software, should always be mains connected alas.

    Portability will always be limited. Hang in there and good luck!

  10. #10
    Iomega Portable Hard Drive not mounting

    Member Since
    Mar 23, 2009
    Posts
    6
    iomega hard drive
    All's well that ends well!
    Iomega sent me a y-shaped usb cable, and the hdd is now working perfectly!

    harryb2448, thanks for your help, mate!

  11. #11
    Iomega Portable Hard Drive not mounting
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,020
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    No problems and hang in there seanachie. Macforums is a great place so make sure you bookmark here!

  12. #12
    Iomega Portable Hard Drive not mounting

    Member Since
    Jan 03, 2011
    Posts
    2
    My Iomega eGo 320 portable drive's not dead. I get the power light on the external drive unit and it's repeating a squeaking/rubbing noise; and it seems to be sucking a lot of battery juice. Two Mac desktops recognize the drive fine, but my PowerBook G4 (OS 10.4.11) USB (bus speed 167mh) laptop won't. Iomega shipped it with a 2-port USB wire, but my 2 ports are 2 far apart for them to reach. Since power is going to the unit, could the problem be something other than not enough power? (If so, please dumb down your answer well below what you think a dummy would understand. I live in silicon valley, but nothing's oozed in so far.) thx

  13. #13
    Iomega Portable Hard Drive not mounting
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,202
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    It's not getting enough power. The iOmega drives are famous for drawing lots of current - that's the reason they supplied a dual USB cord. Probably best to get an AC adapter and use it instead when you hook it up to your PowerBook.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can't Search Iomega Hard Drive
    By MSK in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 09-27-2012, 01:13 PM
  2. Iomega 500 GB Drive Mounting Issues
    By scullery in forum Other Hardware and Peripherals
    Replies: 6
    Last Post: 04-03-2012, 11:06 AM
  3. portable iOmega external hard drive not working at all!...please help!
    By MS12 in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 06-22-2011, 03:20 PM
  4. 500 GB Iomega eGo Helium Portable Hard Drive
    By G5flyr in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 10-03-2010, 02:28 PM
  5. Help- Iomega external hard drive
    By gary in forum Other Hardware and Peripherals
    Replies: 2
    Last Post: 07-17-2007, 01:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •