Hi all,

I am new to Mac's but so far have been very pleased with the quality of my MacBook.

I used BootCamp to put a dual XP boot on.

200GB drive:
30 - OSX
30 - XP
160 - Data

The OSX and XP partitions work fine, and XP installed without any problems.

The data partition hasnt been so simple in that I cannot format it from my Mac. I want to format it as MS-DOS FAT32 so it can be read by both OSs, but in the Disk Utilities app this is not an option...

In the erase tab the ONLY options are:
Mac OS Extended (Journaled)
Mac OS Extended
*The MS-DOS FAT32 option is not listed in the drop down menu (as it should be according to everyone).

SO I tried doing it via the terminal...

Last login: Thu Aug 23 00:52:57 on console
Welcome to Darwin!
xxxs-computer:~ xxx$ diskutil list
/dev/disk0

#: type name size identifier

0: GUID_partition_scheme *186.3 GB disk0

1: EFI 200.0 MB disk0s1

2: Apple_HFS Macintosh HD 30.0 GB disk0s2

3: Apple_HFS Data 119.9 GB disk0s3

4: Microsoft Basic Data Untitled 36.0 GB disk0s4
/dev/disk1

#: type name size identifier

0: Apple_partition_scheme *100.0 MB disk1

1: Apple_partition_map 31.5 KB disk1s1

2: Apple_HFS Skype 100.0 MB disk1s2
xxxs-computer:~ xxx$ fdisk /dev/rdisk0
fdisk: /dev/rdisk0: Permission denied
xxxs-computer:~ xxx$ fdisk /dev/rdisk0s3
fdisk: /dev/rdisk0s3: Permission denied
xxxs-computer:~ xxx$ sudo newfs_msdos -F32 /dev/rdisk0s3
Password:
newfs_msdos: /dev/rdisk0s3 is mounted on /Volumes/Data
xxxs-computer:~ xxx$ diskutil list
/dev/disk0

#: type name size identifier

0: GUID_partition_scheme *186.3 GB disk0

1: EFI 200.0 MB disk0s1

2: Apple_HFS Macintosh HD 30.0 GB disk0s2

3: Apple_HFS Data 119.9 GB disk0s3

4: Microsoft Basic Data Untitled 36.0 GB disk0s4
/dev/disk1

#: type name size identifier

0: Apple_partition_scheme *100.0 MB disk1

1: Apple_partition_map 31.5 KB disk1s1

2: Apple_HFS Skype 100.0 MB disk1s2
xxxs-computer:~ xxx$

But as you can see...it didn't work as it still says Apple_HFS for it.

I have a MacBook, 2.16GHz, 2GB RAM - Tiger 10.4.10

I have spent alot of time online searching for this but can't find anyone with the same problem, hence the post.

Thanks in advance for your help.

Iain, Mac Newbie