Results 1 to 6 of 6
  1. #1
    Macintosh HD disappeared from Disk Utility on boot...

    Member Since
    Oct 09, 2012
    Posts
    7
    Macintosh HD disappeared from Disk Utility on boot...
    I'm trying to troubleshoot my brother's black Macbook (10,4). Upon powering on, the screen goes white. I know about all the commands; I've tried them all. Two times I've been able to click on the OS X Installer disk and get to the Disk Utility from the Utilities tab. What was strange is I never saw the Macintosh HD but instead 'HitachiHTS54...' and 'disk4s2' (the former one had all the 128something GB on it). I tried repairing the disk and doing a few other things, but the disk couldn't be repaired. I closed out of this and powered off the computer yet again.

    However... since then, I've not been able to get back to the Disk Utility by clicking on the Installer disk (getting there by holding down C while booting). I know my keys are working because I see the arrow when I hold down Option/Alt and see the folder with question mark when holding down C. This is really frustrating because, at this point, I don't care if everything's been lost on the hard drive. I just want to get back to where I was at to clean install, but can't figure out a work around.

    I've been searching everywhere for answers and finally got a solution:

    1.- Remove the hard drive.
    2.- Boot off the startup CD and set boot option to CD. Then just shutdown. Donít restart yet.
    3.- Plug in the hard drive and power on the Macbook WITH the CD inserted. It should boot off the CD as instructed.
    4.- Using the hard drive utils, FORMAT the hard drive.
    5.- Restart now without the CD in. It should boot.

    Notes: a) if at step 2, after setting boot option to CD, it only gives you the restart option, then plug in the hard drive while computer still on and restart (without removing the CD, of course, so that it can boot again).
    b) yes, when you change boot options from bootable CD, those changes apply next time you boot.
    c) you HAVE TO format your hard drive before trying to boot off it; otherwise you get the white screen again because the firmware is trying to find the boot sector in your hard drive.


    Since I saw only the restart option as mentioned in 'Notes', I followed the steps given. I was able to finally get back to where I was, however, the 'HitachiHTS54...' and 'disk4s2' were both missing.

    Is there a chance maybe I didn't insert the hard drive back in all the way? I did everything precisely. Does anyone know why I was seeing 'HitachiHTS54...' and 'disk4s2' in the first place, and why I can not see it now (12 hours later)? Is my hard drive ruined? If so, why was I able to see 'HitachiHTS54...' and 'disk4s2' with data on it? Is there a way I can get the hard drive to show again in disk utility upon booting?

    Please, if you have an answer or suggestion or another thread to answer my specific concern, do let me know!

  2. #2
    Macintosh HD disappeared from Disk Utility on boot...

    Member Since
    Apr 24, 2009
    Location
    UK
    Posts
    593
    Specs:
    MacBook Pro 15" 2.8 GHz
    From what you've tried the hard drive is almost certainly defective. It's a simple and inexpensive job to replace and reinstall the OS.
    Steve
    UK

  3. #3
    Macintosh HD disappeared from Disk Utility on boot...

    Member Since
    Oct 09, 2012
    Posts
    7
    Quote Originally Posted by techiesteve View Post
    From what you've tried the hard drive is almost certainly defective. It's a simple and inexpensive job to replace and reinstall the OS.
    Thank you for your quick reply. Do you know on average how much a hard drive would cost? With around the same 125 GBs?

    I just find it very odd that last night I was able to see a hard drive within Disk Utility and now I can't. If anyone else knows a trick around this, do let me know.

  4. #4
    Macintosh HD disappeared from Disk Utility on boot...
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,014
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    There is a chance the SATA cable has fractured when you removed the drive. They are pretty fragile and time and heat play their part.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

  5. #5
    Macintosh HD disappeared from Disk Utility on boot...

    Member Since
    Oct 09, 2012
    Posts
    7
    Quote Originally Posted by harryb2448 View Post
    There is a chance the SATA cable has fractured when you removed the drive. They are pretty fragile and time and heat play their part.
    Thanks for your input.

    Does this mean I could replace solely the SATA cable? Or is it the part it connects to on the hard drive what might have been fractured?

  6. #6
    Macintosh HD disappeared from Disk Utility on boot...
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    20,014
    Specs:
    iMac i5 2.7GHz, 16GB memory, OS 10.10.5
    Posted in your other thread. If you replace the drive replace the cable.
    Hang on to those original install discs like grim death! Using OS X.7 or later make a bootable USB thumb drive before running Installer!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I accidentally erased Macintosh HD using Disk Utility please help
    By basolis14 in forum OS X - Operating System
    Replies: 4
    Last Post: 07-13-2014, 05:10 AM
  2. ' macintosh hd' not showing at startup or disk utility
    By Honorandlove in forum OS X - Operating System
    Replies: 6
    Last Post: 05-18-2014, 06:11 PM
  3. Disk Utility Disappeared after upgrade?
    By secretsof2113 in forum OS X - Operating System
    Replies: 3
    Last Post: 10-27-2008, 03:32 PM
  4. Disk Utility disappeared!
    By JoannaD in forum OS X - Operating System
    Replies: 3
    Last Post: 07-06-2008, 07:00 AM
  5. Disk utility>Macintosh HD>NEW IMAGE = Resource busy???? wtf
    By NavyElk in forum OS X - Operating System
    Replies: 2
    Last Post: 07-08-2005, 11:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •