WIll Lion/Mountain Lion run older versions of Quark XPress (6.5) and Photoshop (CS2)?