Results 1 to 15 of 15
  1. #1
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    Web pages will not load...
    I've looked all over this forum and elsewhere, and can not find a solution...
    My iMac will not load certain websites, notably Facebook. Iíve looked for software updates, I've reset my router even though those sites work fine on the PC and smartphones using the same network. I have tried using Safari, Firefox, and Chrome with no luck. I have cleared all browsing data and caches etc, and still no luck. I have even changed my DNS servers and that seemed to help for 5 minutes, but now I am back to square one... I've tried everything for over a month now. Very frustrating. Please help me!

    I am running Mac OS X 10.5.8

  2. #2
    Web pages will not load...
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,224
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    Copy and post your "Hosts" file for us to take a look at. Here's how to find it:

    Open your Finder and navigate to

    MacIntosh HD/etc/hosts

    Open the hosts file with textedit and copy it to your clipboard. Then paste it here. Here is what mine looks like to give you an idea...

    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting. Do not change this entry.
    ##
    127.0.0.1 localhost
    255.255.255.255 broadcasthost
    ::1 localhost
    fe80::1%lo0 localhost

  3. #3
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    I was able to locate /etc/hosts
    except when I tried to open "hosts" it 1) it seems to be a shortcut... 2) It says "the alias "hosts" could not be opened, because the original item cannot be found"

    I remember seeing familiar text by typing something in the terminal, when I was trying to figure this out following another post.
    I can't figure out where I found out how to do that. I thought it was on this forum somewhere, but I can't find it.

    Any ideas?

  4. #4
    Web pages will not load...
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,224
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    It sounds like your hosts file doesn't exist. And why do you have an alias instead of the original?

    How did you try to open it? It can be opened with any text editor or by just double clicking on it. If for some reason the hosts file is gone, just copy mine and place it where it's supposed to be. Copy it exactly as I posted mine. Then, delete the alias.

  5. #5
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    haha ya it sure seems that way...
    I opened it as you normally would. Double click. Then that message popped up.
    How do i make the hosts file?
    Is it just a textedit file?

  6. #6
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    i went to the terminal and typed:

    sudo nano /private/etc/hosts

    to see the hosts file. No surprise, nothing was in there, so I modified it and pasted what you had in there and saved it. Now when i go to /etc/hosts and open it, it shows exactly what you have shown me.
    Seems to still have problems opening facebook though...
    I don't get this at all. I don't know what the problem could be.

  7. #7
    Web pages will not load...
    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,395
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    Quote Originally Posted by chscag View Post
    It sounds like your hosts file doesn't exist. And why do you have an alias instead of the original?
    /etc is a symlink to /private/etc. This is why things in /etc point to the equivalent in /private/etc.

    Ghemp: Try flushing your DNS cache:
    dscacheutil -flushcache
    It's possible that you've got some weird IP cached for Facebook.
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  8. #8
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    ya, i have tried that before, and i tried again, but no luck

  9. #9
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    after trying to open facebook, it timed out and gave me this message, i don't know if this helps:

    Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.


    ideas anyone?
    (Using chrome)

  10. #10
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    I found this to be curious
    When I am using Firefox a message will randomly come up (even though I have not clicked on anything) and I will be on a completely different website...

    You have chosen to open
    like.php
    which is a: php File
    from: Welcome to Facebook - Log In, Sign Up or Learn More
    What should Firefox do with this file?

    Is this another indication that facebook's IP address is being redirected or firewalled or something.
    Is there a way to see blocked IP addresses or something?

  11. #11
    Web pages will not load...
    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,395
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    PHP files, initially interpreted by the PHP interpreter on the server, return HTML which should be parsed by your browser. In other words, you shouldn't be getting the open/save dialog for PHP files. The only time that something like this generally happens is when a server configuration has gone wrong and I doubt this is the case in this instance.

    Who provides your DNS settings? Do you just use what your ISP provides or do you use a third party service like OpenDNS?
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  12. #12
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    i recently just switched to OpenDNS in hopes it would solve the problem.
    I did their test to ensure i was using their servers, it passed.
    But they sent me an email saying there's one more step of adding IP addresses, or a range of IP's
    I'm not sure what IP's to submit, if any.
    Would adding some help?

  13. #13
    Web pages will not load...
    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,395
    Specs:
    2012 13" MBP (2.5 i5, 8GB)
    If you passed the test, you're fine - you don't need to do anything else.

    If you just switched, OpenDNS won't be blocking Facebook. Blocking a domain requires setting up an account with them and explicitly listing FB as a blocked domain so you'd know if it happens.

    I want to try something. You mentioned that changing your DNS fixed it temporarily. Have you tried going to Facebook by using it's IP? If not, try going to http://66.220.149.11 (that's FB's IP).
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

  14. #14
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    yes, I have tried that.
    unfortunately, it doesn't work either.

    I was able to get on today, but only for about 5 minutes before facebook wouldn't respond anymore.
    It doesn't make sense to me.

    I still try other browsers, chrome seems to work the best.
    Safari won't even let me on Google half the time.

  15. #15
    Web pages will not load...

    Member Since
    Jun 10, 2012
    Posts
    10
    Just for anybody reading these posts, the problem was never resolved for me
    UNTIL
    I upgraded my OS from Leopard to Mountain Lion
    I am pretty sure all my internet problems were solely from my outdated OS.
    A lot of sites stopped supporting updates to software etc.
    After getting Mountain Lion, i fell in love with my mac again.
    It's like a new iMac!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Web pages won't load
    By Crag52 in forum OS X - Operating System
    Replies: 19
    Last Post: 08-05-2013, 09:00 PM
  2. iBook won't load web pages...
    By JenC in forum Apple Notebooks
    Replies: 5
    Last Post: 05-24-2010, 09:29 PM
  3. Some Web Pages Will Not Load?
    By TheTeejinator in forum Apple Notebooks
    Replies: 4
    Last Post: 12-31-2009, 12:12 PM
  4. Web pages slow to load
    By Gotta Question in forum OS X - Operating System
    Replies: 7
    Last Post: 08-21-2009, 12:11 PM
  5. Certain web pages will not load
    By Sawday in forum OS X - Apps and Games
    Replies: 3
    Last Post: 04-11-2009, 12:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •