Results 1 to 2 of 2
  1. #1
    What's the newest version of OSX I can use?

    Member Since
    Oct 04, 2007
    Posts
    66
    What's the newest version of OSX I can use?
    Recently acquired an old lamp G4 iMac. What's the highest version of Leopard I can install on this thing? Thanks.

  2. #2
    What's the newest version of OSX I can use?
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    28,477
    Specs:
    iMac late 2007 10.11.b4, iMac 2008 10.10.5, Macbook2007 10.7.5, Mac Mini 10.7.5, iPhone 3GS Note 8!!
    What is the CPU's speed in that G4 iMac? Click the Apple and on About This Mac. Report back.

    If it's 867 Mhz and above, you can run 10.5 Leopard. If not, 10.4 Tiger.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrading to the newest version of Pages
    By BDD888 in forum OS X - Apps and Games
    Replies: 1
    Last Post: 10-29-2013, 03:29 PM
  2. Old Garageband songs in newest version
    By iWish in forum Music, Audio, and Podcasting
    Replies: 0
    Last Post: 08-06-2010, 02:19 AM
  3. 10.4.11 to newest version error?
    By Mac Na'gev in forum OS X - Operating System
    Replies: 3
    Last Post: 01-22-2009, 05:40 PM
  4. The newest version the better? leopard vs tiger
    By ric0h in forum OS X - Operating System
    Replies: 7
    Last Post: 08-11-2007, 05:43 PM
  5. Newest Version Parallel Issues
    By DeathtoToasters in forum Running Windows (or anything else) on your Mac
    Replies: 1
    Last Post: 03-19-2007, 11:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •