Results 1 to 5 of 5
  1. #1
    HELP problem adding users

    Member Since
    Aug 19, 2010
    Posts
    2
    HELP problem adding users
    I didn't find anything similar when searching so here goes.

    I am using snow leopard on both imac and mac Pro computers. Whenever I need to add new users (it is a research lab with new people coming) I do the following:
    1. Log in as me
    2. Go to System Preferences > Accounts
    3. Click lock and type in administrator information
    4. Click the plus sign to add new user
    5. type in user name, account name, password and verify password
    6. Click "Create Account" button

    When I click the button at the end the beachball comes up and the computer slows down drastically. I let the computer set and when I came back two days later it was still stuck there. The only thing I can do is force quit the computer or shut it down.
    Whenever I go to add the user again it won't let me because it says the user already exists though it is not in the user list.

    What do I need to do to either get the user into the user list or to delete it so I can retry it. I have 6 computers that I need to add the new users to and it will make life a lot easier if the user name is the same on all of them.

  2. #2
    HELP problem adding users
    brairden's Avatar
    Member Since
    Jul 24, 2010
    Location
    Dayton, Ohio
    Posts
    252
    Specs:
    2 iMacs, 1 MBP, 1 UMB, 1 mini
    I would try using a terminal utility command (dscl) to delete the user.

    dscl . -delete /Users/username

    This will delete the user, but not the home folder (if there is one).
    But you could just manually delete the home folder anyway.
    15" 2.53ghz i5 MacBook Pro (2010) 8gb, 500gb HD - 60gb OWC SSD
    13" 2.4ghz MacBook Unibody (late 2008) 4gb, 250gb
    24" 2.4ghz Aluminum iMac (mid 2007) 3gb, 1tb
    mini 2.0ghz - 32gb iPhone 4

  3. #3
    HELP problem adding users

    Member Since
    Aug 19, 2010
    Posts
    2
    Thanks. I was not aware of the dscl command.

    Can anyone think of an explanation as to why it freezes up in the first place?

  4. #4
    HELP problem adding users
    brairden's Avatar
    Member Since
    Jul 24, 2010
    Location
    Dayton, Ohio
    Posts
    252
    Specs:
    2 iMacs, 1 MBP, 1 UMB, 1 mini
    That would be very tough to say. Haven't heard of this as a widespread problem. We would all just be guessing....let's just hope that this solution works and it allows you to recreate the user again without issue.
    15" 2.53ghz i5 MacBook Pro (2010) 8gb, 500gb HD - 60gb OWC SSD
    13" 2.4ghz MacBook Unibody (late 2008) 4gb, 250gb
    24" 2.4ghz Aluminum iMac (mid 2007) 3gb, 1tb
    mini 2.0ghz - 32gb iPhone 4

  5. #5
    HELP problem adding users

    Member Since
    Jun 21, 2011
    Posts
    3
    Attempted delete as Admin - permission error
    Hello,

    I've experience this same issue and attempted the terminal command you recommend logged in as administrator and get a permissions error.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. changing default /Users dir when adding an SSD
    By coltrane in forum Switcher Hangout
    Replies: 4
    Last Post: 04-24-2014, 02:30 PM
  2. Script for adding users
    By i_eat_short_ppl in forum OS X - Operating System
    Replies: 0
    Last Post: 06-04-2009, 06:01 PM
  3. Creating / adding users
    By vaughan80 in forum Switcher Hangout
    Replies: 3
    Last Post: 10-08-2007, 06:25 PM
  4. adding contact problem..
    By shadyboi in forum Switcher Hangout
    Replies: 1
    Last Post: 09-07-2007, 07:40 AM
  5. problem with adding soundtrack to imovie
    By TW MILLS in forum Movies and Video
    Replies: 2
    Last Post: 09-23-2006, 01:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •