Results 1 to 10 of 10
  1. #1
    Webpages not rendering correctly

    Member Since
    Jan 06, 2008
    Posts
    13
    Webpages not rendering correctly
    Hello, I've read around on this forum alot in the past and decided to get a macbook a little over a year ago. I have a 3,1 Macbook (2GHz Intel C2D, upgraded to 2.5GB of RAM and 250gb harddrive).

    I had everything running fine for over a year with no problems but I decided to reinstall everything just to clean out some stuff (yes I did use Onyx if anybody asks why didn't I just use something like that). When I reinstalled OS X I had some issues rendering website across many browsers (Firefox 3, Safari, Camino) with mainly Facebook but also a few others. I searched around some finding different things and trying them out. I updated to the newest version of Java (and also checked to make sure it was enabled in Firefox many times) and reinstalled Xcode. I also tried the Xcode tools from Apple's Developer Connection but none of these things worked.

    So I reinstalled OS X from scratch again and it was rendering everything normally, then I let it install the updates and afterwards it didn't work again. That led me to believe it had to do with the software update somehow.

    After that I reinstalled everything from scratch again and waited to install the updates. I choose to start with GarageBand Update (4.1.1) and AirPort Utility (5.3.2) thinking neither of those would really impact it. After doing this it did not render properly once again.

    Finally I reinstalled again from scratch and this time again, it does not work before I have even installed any updates, so at the moment I am updating some things (Combined update at the moment) just to see if that makes any difference.

    Has anyone else had a problem like this or know what might be causing it? I'm unsure whether this even has anything to do with Java or not either. I have googled and googled and haven't found any solution and the problem seems to be completely random.

    Each time I installed, it was from scratch, meaning I choose to erase the harddrive and do a new installation (not upgrade) with the discs that come with the macbook. I attached a picture of what Facebook looked like incase you didn't understand what I meant by not rendering correctly. Everything else seems to work normally, just the "rendering" of some webpages. Hopefully this is just something little that I missed somewhere...

    Thanks!

    Picture 1.png

  2. #2
    Webpages not rendering correctly
    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,206
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '11 1.8 i7 4GB 10.10; 21" iMac '13 2.9 i5 8GB 10.10; 5s & 5c
    Opera can do that with any web page. In Opera, it''s called Author Mode. Now I don't have a clue what that means. I know it has to do with the CSS Style Sheets, and that it is the developer's (the site author's) view and that's about it. I'm no web guy.

    Try Opera and turn on the View Bar to check it out. You can switch between Author Mode and User Mode which will change the Style Sheet being used. You can even create your own style sheets (which I've never done).
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  3. #3
    Webpages not rendering correctly

    Member Since
    Jan 06, 2008
    Posts
    13
    Ok I'll give that a try. I think it's kind of strange that it worked before I reinstalled everything though but then again I don't really know much in that area...

    Thanks!

  4. #4
    Webpages not rendering correctly

    Member Since
    Jan 06, 2008
    Posts
    13
    Yeah, that doesn't work either. It says Javascript is disabled on my browser but in the preferences it is turned on and the newest version of Java was downloaded in the updates.

  5. #5
    Webpages not rendering correctly
    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,206
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '11 1.8 i7 4GB 10.10; 21" iMac '13 2.9 i5 8GB 10.10; 5s & 5c
    In Safari, when it is displaying a page in Author mode - while you're on that page, open up Preferences - Advanced and what is in the box labeled 'Style sheet'?
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  6. #6
    Webpages not rendering correctly

    Member Since
    Jan 06, 2008
    Posts
    13
    It says "none selected" and the only other option is "other" which takes you to browse through your files.

  7. #7
    Webpages not rendering correctly
    bobtomay's Avatar
    Member Since
    Dec 22, 2006
    Location
    Texas, where else?
    Posts
    26,206
    Specs:
    15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '11 1.8 i7 4GB 10.10; 21" iMac '13 2.9 i5 8GB 10.10; 5s & 5c
    Don't have a clue. That's the extent of my knowledge about CSS.
    I cannot be held responsible for the things that come out of my mouth.
    In the Windows world, most everything folks don't understand is called a virus.

  8. #8
    Webpages not rendering correctly

    Member Since
    Jan 06, 2008
    Posts
    13
    Hmm...well thanks for trying. I'll mess around some more and see if I can get it to work. I've had a couple of other ideas but I doubt they will help any...

  9. #9
    Webpages not rendering correctly
    deer dance's Avatar
    Member Since
    Jan 23, 2009
    Location
    Indiana
    Posts
    162
    Specs:
    Soon to own
    ...
    The internet doesn't give a poop what you do outside of the web browser, reinstall the browsers and things should clear up.

    Proud Python Programmer/HTML Expert
    Believer in Mac OS 7

  10. #10
    Webpages not rendering correctly

    Member Since
    Jan 06, 2008
    Posts
    13
    Yes I have tried reinstalling them many times. I just reinstalled OS X again hoping it would fix it and here's what happened. The Facebook login page works correctly but not once I'm logged in, and it only works in Safari. Youtube does not work correctly either. Very strange and random...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. some webpages not displaying correctly
    By jediracer in forum Internet, Networking, and Wireless
    Replies: 6
    Last Post: 01-20-2014, 04:28 AM
  2. Webpages timing out
    By agdesign in forum Internet, Networking, and Wireless
    Replies: 3
    Last Post: 01-31-2012, 02:07 PM
  3. Can't view any webpages
    By dl2962 in forum OS X - Operating System
    Replies: 7
    Last Post: 08-02-2009, 10:49 PM
  4. webpages will not load
    By laurit1 in forum OS X - Apps and Games
    Replies: 8
    Last Post: 01-24-2007, 06:36 PM
  5. IE 5.01 keeps on refreshing webpages
    By owy in forum Running Windows (or anything else) on your Mac
    Replies: 0
    Last Post: 05-16-2004, 10:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •