Results 1 to 6 of 6
  1. #1
    Continuous Problem With - Application Installer Quitting
    JBannister's Avatar
    Member Since
    Apr 20, 2007
    Location
    Temple, GA
    Posts
    91
    Continuous Problem With - Application Installer Quitting
    I'm not sure as to when this started happening, but everytime I try to install new software I automatically get the good old "the application installer quit unexpectedly" error. I'm pretty angry about this seeing as it reminds me of pos windows machines; any help would be greatly appreciated.

  2. #2
    Continuous Problem With - Application Installer Quitting
    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,637
    First thing to try is repairing permissions. If you don't have a utility like Onyx or MainMenu to do that, you may have to use Apple's Disk Utility since those two might require the installer.

    If that doesn't work, try creating a new user and see if the problem recurs with that user.

    Also try installing something while in "Safe" mode. You get to Safe Mode by rebooting, then pressing and holding down the "shift" key as soon as you hear the startup chime until you see the grey Apple logo and spinning progress indicator.

    Let us know what happens. We can go from there.

  3. #3
    Continuous Problem With - Application Installer Quitting
    JBannister's Avatar
    Member Since
    Apr 20, 2007
    Location
    Temple, GA
    Posts
    91
    Well I tried the last two things and neither one worked; well I couldn't even get it into safe mode because it just sat there for like 5 minutes. How exactly do i repair permissions. It doesn't give me any options when I am viewing the disk in disk utility.

  4. #4
    Continuous Problem With - Application Installer Quitting
    JBannister's Avatar
    Member Since
    Apr 20, 2007
    Location
    Temple, GA
    Posts
    91
    It won't even let me select repair permissions.

  5. #5
    Continuous Problem With - Application Installer Quitting
    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,637
    Alrighty. Well offhand, it sounds like you have something seriously corrupted in your system. What it is exactly is tough to say. There's one thing you can try to avoid reinstalling the OS completely, but be sure you do this exactly.

    EDIT: Do this first actually... we should make sure the disk drive isn't going bad: Boot from the DVD, exit the OS installer, and run Disk Utility from the DVD. Have it verify the disk (and repair permissions). Directions here.

    If the disk checks out OK but the permissions repair doesn't work, then read on...

    Make a copy of /Library... name it Library-Old, or something like that. /Library is the folder you see if you are looking at the contents of your disk drive. Once you are sure you have the right folder and have a backup copy, delete the original /Library. Do NOT delete the Library folder that is found under the System folder, nor the one under your user's home folder. You may have to boot from the install DVD in order to do this. OS X will rebuild the Library from scratch... you'll have a virgin, untainted copy.

    With any luck, this will solve your problem. It may break some applications... just reinstall those. Again... be absolutely sure you are deleting the correct Library folder and have the backup just in case. Barring this... I don't an alternative aside from reinstalling. As long as the problem isn't rooted in the System folder somewhere, this should work.

  6. #6
    Continuous Problem With - Application Installer Quitting
    JBannister's Avatar
    Member Since
    Apr 20, 2007
    Location
    Temple, GA
    Posts
    91
    Alright well I don't exactly how to do the whole /Library thing or what not so I'll prolly just end up reinstalling the entire system. I did this in January before I put in the new OS because I usually like to clean things up so I know there is nothing affecting it prior to the new OS. If I have any other questions I'll PM you. Thanks for the info.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Quitting application
    By chris_cooper_25 in forum OS X - Operating System
    Replies: 4
    Last Post: 01-21-2013, 01:14 PM
  2. Problem with apps quitting
    By joeg679 in forum OS X - Apps and Games
    Replies: 7
    Last Post: 08-08-2011, 06:59 AM
  3. Application Quitting at Launch (1/3)
    By MacUserTrey in forum OS X - Apps and Games
    Replies: 3
    Last Post: 12-12-2010, 08:47 PM
  4. Creating an installer for my first Cocoa Application
    By mbm30075 in forum OS X - Development and Darwin
    Replies: 12
    Last Post: 03-13-2010, 01:15 AM
  5. Installer app quitting on me
    By 3cho7even in forum OS X - Operating System
    Replies: 0
    Last Post: 02-16-2009, 09:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •