Got X11, X11SDK, and Macports installed.
Tried installing something simple, a window manager, Blackbox.
This is what I get:
Code:
--->  Configuring blackbox
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_blackbox/work/blackbox-0.70.1" && ./configure --prefix=/opt/local --prefix=/opt/local --mandir=/opt/local/share/man " returned error 1
Command output: checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... no
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by /usr/bin/g++-4.0... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking whether the /usr/bin/g++-4.0 linker (/usr/bin/ld) supports shared libraries... yes
checking for /usr/bin/g++-4.0 option to produce PIC... -fno-common
checking if /usr/bin/g++-4.0 PIC flag -fno-common works... yes
checking if /usr/bin/g++-4.0 supports -c -o file.o... yes
checking whether the /usr/bin/g++-4.0 linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin8.11.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking for sed... sed
checking for gencat... gencat
checking for iconv_open... no
checking for iconv_open in -liconv... no
checking for libiconv_open in -liconv... yes
checking for GNU libiconv... yes
checking for setlocale... yes
checking for nl_langinfo... yes
checking for t_open in -lnsl... no
checking for socket in -lsocket... no
checking for X... no
configure: error: Blackbox requires the X Window System libraries and headers.

Error: Status 1 encountered during processing.
X is installed. I've used it with Fink, currently not installed.
This is my $PATH:
Code:
/opt/local/bin:/opt/local/sbin:/usr/X11R6/bin:
/usr/X11R6/lib:/usr/X11R6/include:
/usr/X11R6/man:/usr/local/bin:/usr/include:/bin:/sbin:
/usr/bin:/usr/sbin:/usr/local/bin
Most of the stuff I've tried to install tells me that X isn't there.
Is there some way I can tell Macports that X is there?
Or is there another problem somewhere?