I am trying to use macports to install a software on my OS X 10.7, and I get the following error message:

Error: The installed version of Xcode (3.2.6) is too old to use on the installed OS version. Version 4.1 or later is recommended on Mac OS X 10.7.

I have Xcode 4.3.3 installed, so I would be grateful for your suggestions of how to make it the default Xcode being used.