Why are some ports so old? Specifically I am referring to Samba3. The current stable release is 3.5.1 but Macports continues to only make 3.2.15 available.

Is there a reason for this or has the port file not been updated?