Ok I deleted safari by mistake but now I tried to install Safari 1.2 and update to safari 2. Problem is that during the installer it says that it cannot install because it does not meet the requirements. What?!