I reinstalled Safari today on my intel iMac from my OS X install disc.

My install disc is for OS X 10.4.4 and so the version of Safari it installed is 2.0.3 (417.8)

I need to update Safari now to 2.0.4 (419.3) so as it will be compatible with the latest version of Saft.

However Software Update does not recognise that Safari is not the latest verion because the Safari update was part of the update to Mac OS X 10.4.7, which I installed in August, and have since further updated to Mac OS X 10.4.8 in October.

I attempted to run the Mac OS X 10.4.7 Intel update again but my HD Volume "does not meet the requirements for the update" - presumably because I have already installed it previously and another update on top of it.

I also considered resorting to use an older version of Saft but although the site (http://haoli.dnsalias.com/Saft/Download/index.html) lists previous versions - all download links lead to a download of the latest version which is incompatible with my version of Safari.

Does anyone please have any suggestions for how I can update to the latest Safari?

Thank you
Oisin