I have Numbers 3.0 installed, shows clearly on the Dock. Dock points to Applications folder, all looks good.

I opened a .csv that had been sent to me, it opened just fine in the new Numbers. I then saved it as a Numbers file. When I went to open the .numbers file by double clicking it, it said I needed an updated version of Numbers. I looked at Get Info on the file, and it was properly pointing to Numbers 3.0 as the default application. If I open Numbers from the Dock, it can open the file just fine, but double-clicking on the file results in the error every time. I re-opened Get Info and verified that it was pointing to Numbers3.0 as the default and then updated so that EVERY .numbers file was pointing to Numbers3.0, but the file still throws up the error message.

I tried another Numbers spreadsheet, it opened in the 2.3 version of Numbers, I guess from my TimeMachine backup. I closed it, right clicked and chose Numbers 3.0, which was showing as the default, got a message about the file changing for the new Numbers and then saved it from Numbers 3.0. Reopening it opened in Numbers 3.0, but when I repeated with a new .numbers file it was Numbers 2.3 again, even though it again shows Numbers 3.0 as the default. I unmounted my backup drives and tried again. This time double-clicking on any Numbers file opens in Numbers 3.0. Do I have to purge my backups of Numbers 2.3 to get it to use the default Numbers 3.0? If true, that's crazy, and bad programming on Apple's part.

Any clues for me?