Page 1 of 3 123 LastLast
Results 1 to 15 of 42
  1. #1
    Safari and youtube issues

    Member Since
    Feb 17, 2011
    Posts
    2
    Unhappy Youtube won't work now.
    Hi everyone, just new to this forum.

    Not sure where i should be posting this message :/

    Just wondering if anyone could help me... Just recently viewing Youtube videos isn't working in Safari.

    I've tried Firefox and works fine but not in Safari.
    Also, I have tried to find the problem myself and found out that when i go to the users page, I can view their videos from there but on the videos pages, they don't seem to work.

    I haven't changed any settings that I know of and has only occured today.

    EDIT: I have also tried clearing cache, cookies etc but still no luck

    Any help would be great

    Thanks in advance

  2. #2
    Safari and youtube issues
    iWhat's Avatar
    Member Since
    Nov 11, 2004
    Location
    Toledo, Ohio
    Posts
    5,736
    Specs:
    Macbook, iMac G5, iPad, iPhone 4, iPod (MANY)!
    Repairing permissions worked with the last member who had this issue. Then restart.

  3. #3
    Safari and youtube issues
    JUKE179r's Avatar
    Member Since
    Nov 01, 2009
    Location
    DohaLondonVegas
    Posts
    882
    Specs:
    '07 MBP 256GB SSD/6GB RAM/SL <--DAW!!!
    I've had the same problem for 3 weeks now and ended up using firefox instead.
    I searched on here and already repaired permissions, removed/reinstalled adobe flash, cleared the cache, and removed all extensions and still can't watch vids.
    I don't want to remove Safari (via AppZapper) and reinstall it just because i have a bunch of website passwords saved and don't want to lose them.

    Any other ways to tackle this? Cheers!
    MBP 3,1 & 4,1 w/ Vertex 4 SSD | Logic Pro 9 | Ableton Live 8 | Traktor Pro 2 | AKAI MPK-49 | Roland MV-8000, TR-808 & TR-909 | Ensoniq ASR-10 | x0xb0x #911 | Denon DN-MC6000 | (3) Technics SL-1200MK1 | 3000+ vinyl records

  4. #4
    Safari and youtube issues

    Member Since
    Sep 05, 2007
    Posts
    69
    Safari and youtube issues
    I am having issues with playing videos in safari off youtube. It just started all of a sudden and the screen is blank where the video should be. I have tried reinstalling flash as well as reseting safari. I am still having the same problem, I have no idea why it started as well. Videos work in firefox though. Can anyone recommend anything else?

  5. #5
    Safari and youtube issues
    Buzzard2010's Avatar
    Member Since
    Oct 22, 2010
    Location
    Bretforton, Worcestershire
    Posts
    2,571
    Specs:
    MacBook Pro 15" 2014, 2.2GHz i7, 16GB RAM, 250GB SSD, OSX 10.9.5 - iPhone 5s 16gb
    Sounds stupid but have you tried re-booting your machine?

    - Simon

    If you have been helped, don't forget to use the Reputation system at the top right of their post.
    May 2011
    Nominated: March 2011 & April 2011

  6. #6
    Safari and youtube issues

    Member Since
    Sep 05, 2007
    Posts
    69
    its not stupid but yes, that was the first thing I tried

  7. #7
    Safari and youtube issues
    Buzzard2010's Avatar
    Member Since
    Oct 22, 2010
    Location
    Bretforton, Worcestershire
    Posts
    2,571
    Specs:
    MacBook Pro 15" 2014, 2.2GHz i7, 16GB RAM, 250GB SSD, OSX 10.9.5 - iPhone 5s 16gb
    Try downloading and re-installing Safari!

    - Simon

    If you have been helped, don't forget to use the Reputation system at the top right of their post.
    May 2011
    Nominated: March 2011 & April 2011

  8. #8
    Safari and youtube issues

    Member Since
    Sep 05, 2007
    Posts
    69
    didn't work

  9. #9
    Safari and youtube issues
    Kevriano's Avatar
    Member Since
    Jul 02, 2006
    Location
    Crawley, England
    Posts
    4,558
    Specs:
    20" Intel iMac 2.4 Ghz/3G Ram/320HD, Snow Leopard. PBook G4, 1.5Ghz/1.5 Ram/250 HD, Leopard 10.5.6.
    Try a permissions repair in disk utility. While it shouldn't directly affect Safari it may well solve the issue.
    It seems that Safari has lost a plug in somewhere though.
    A couple of things. When you reset Safari did you empty the cache?
    And what version OS are you running on what Mac?
    Try my custom Mac Forums Search Engine: Mac Forums Google Search

    Please use the reputation system if you consider any help given useful (it's the little ✓/✘ on the left <---)


  10. #10
    Safari and youtube issues
    schweb's Avatar
    Member Since
    Oct 27, 2002
    Location
    Cleveland, Ohio
    Posts
    13,190
    Specs:
    MacBook Pro | LED Cinema Display | iPhone 4 | iPad 2
    Did you install or change anything before this started happening?
    schweb | community leader
    flickr facebook twitter tumblr google+ about.me

    Mac-Forums: On Twitter | On Facebook | On Flickr


  11. #11
    Safari and youtube issues

    Member Since
    Aug 21, 2007
    Posts
    45
    I'm having the exact same issue,

    there is no 'Play' button and the video area is blank.

    I am on latest OSX, Safari and Flash. I have uninstalled and reinstalled Flash (with reboots) and the behaviour hasn't changed.

    The only system config thing I've changed recently is to add Microsoft Silverlight.

    Ken.

  12. #12
    Safari and youtube issues
    schweb's Avatar
    Member Since
    Oct 27, 2002
    Location
    Cleveland, Ohio
    Posts
    13,190
    Specs:
    MacBook Pro | LED Cinema Display | iPhone 4 | iPad 2
    What version of OS X are you running and which version of Flash?
    schweb | community leader
    flickr facebook twitter tumblr google+ about.me

    Mac-Forums: On Twitter | On Facebook | On Flickr


  13. #13
    Safari and youtube issues

    Member Since
    Sep 23, 2007
    Posts
    2
    I just started having the same exact problem as well on my macbook, youtube was working just fine a couple days ago, but all of a sudden I only see a black screen. I did all the above:

    1. uninstalled+reinstalled flash
    2. cleared cache and cookies
    3. repaired disk permissions
    4. rebooted

    Nothing worked, I didn't install anything new and I'm on the latest version of safari and osx as well. What gives?

  14. #14
    Safari and youtube issues

    Member Since
    Sep 23, 2007
    Posts
    2
    I just started having the same exact problem as well on my macbook, youtube was working just fine a couple days ago, but all of a sudden I only see a black screen. I did all the above:

    1. uninstalled+reinstalled flash
    2. cleared cache and cookies
    3. repaired disk permissions
    4. rebooted

    Nothing worked, I didn't install anything new and I'm on the latest version of safari and osx as well. What gives?

  15. #15
    Safari and youtube issues
    schweb's Avatar
    Member Since
    Oct 27, 2002
    Location
    Cleveland, Ohio
    Posts
    13,190
    Specs:
    MacBook Pro | LED Cinema Display | iPhone 4 | iPad 2
    Quote Originally Posted by JUKE179r View Post
    I don't want to remove Safari (via AppZapper) and reinstall it just because i have a bunch of website passwords saved and don't want to lose them.
    I doubt reinstalling Safari would fix it anyway.

    But as for the passwords, etc, those are stored in your keychain, not Safari.
    schweb | community leader
    flickr facebook twitter tumblr google+ about.me

    Mac-Forums: On Twitter | On Facebook | On Flickr


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why does YouTube look different on Safari?
    By Tarek in forum OS X - Apps and Games
    Replies: 3
    Last Post: 06-22-2013, 08:07 PM
  2. Issues Downloading Youtube vids in safari
    By Quicktime_GT in forum OS X - Operating System
    Replies: 1
    Last Post: 12-10-2010, 10:26 PM
  3. Downloading Youtube with safari issues..
    By Quicktime_GT in forum OS X - Apps and Games
    Replies: 1
    Last Post: 09-08-2010, 08:52 PM
  4. Safari and Youtube
    By Priscilita22 in forum OS X - Operating System
    Replies: 1
    Last Post: 05-29-2008, 07:36 PM
  5. Safari+YouTube
    By nakile in forum iPod Hardware and Accessories
    Replies: 0
    Last Post: 01-22-2008, 08:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •