lastnight i updated my 13 inch mac book from the old quicktime to the new 7.6.6 version. now my itunes says it wont open because quicktime needs to be version 7.5.5 or newer. <?> im a little confused here? kinda new-ish to mac and dont know all the ins-n-outs just yet and need a hand fixing this. if anyone has any suggestions, please let me know! thanks much.