Results 1 to 4 of 4
  1. #1
    Mail Folder "exclusively locked" by user
    Hi Everyone,

    Sorry to make my first post here a real annoying problem, but I am being blamed by a client for something I don't believe is related to my set up.

    Here's how it goes....

    I was contacted by my client to set up another email user on my mail server so that he could use two addresses (at different domains). Both use my mail server for their mail.

    I set the account up on a Friday. I did not inform the client his mail box was ready.

    During the weekend he regularly checked his current account on our server with no problems.

    On the Monday I informed him that his mail was ready to go on our server. He dutifully added the account info to his Mac mail on his G4 Laptop.

    During this process he received an error message telling him that his mail folder was "exclusively locked by user XXXX on [Machine Name Here]". The error informed him that 'opening' his mail folder at the time might damage it. He opened it and about 90% of his mail had disappeared from his mail folder.

    Now, he is adament that it was my server that caused the problem, yet he never even got to check that account on our server, he had the problem before it could even check our system for mail. The error he received was a mac system error, not an error generated by my mail server.

    My mail server is a Windows 2003 server, running 'Merak Mail Server'. I have several clients using Macs, none have ever had problems with my system. It's a standard POP3 set up.

    Now I was wondering if anyone out there has encountered such a problem before, and I'd also like to know if there is anyway his mail can be recovered.

    I'm just upset that he is dead set on it being my problem - regardless of the fact that his machine was checking his current account for two days (while his new account was already functioning on my server) without problems. It was only when he added the account on his mail software that a problem occured.

    Any ideas why the system would have had his mail folder "exclusively locked"?

    He is running a G4 Powerbook with OSX10.3 (I think).

    Excuse my vague-ness over this whole thing - he is in the US and I am in New Zealand.

    He tells me he set the account up correctly etc, but with that error he saw, I can't be sure.

    So to recap:-
    Do any of you think that my mail server caused this problem? (I don't - but I want to hear from you if you do)

    Why did his machine "lock" his mail folder? (he ignored the message and proceeded anyway)

    Can I re-import the folder?

    Any chance that the lost messages can be recovered?

    Thanks in advance, sorry for the long post.


  2. #2
    Am I being ignored because this has already been answered before? Or does no-one have anything to add specifically?

    Either way I'd love to know as I need to get some resolution with my client soon.


    P.S. I couldn't find anything in all the searches I did that involved anything quite like what happened to my client.

  3. #3

    sarahsboy18's Avatar
    Member Since
    Jan 30, 2005
    Fort Worth, Texas
    Mac Pro, 8-Core 2.8Ghz, 10GB RAM, 2x1TB HDDs, iPod U2 Edition
    That sounds like some sort of issue with Mail. He should have paid attention to that warning message for sure... I don't see how it could be a problem with your mail server... The mail server is just a storage place for messages... It has no control over your mail client.

    Clients always try to blame you... But in this case your client is dead wrong about the cause... He needs to check the Apple Mail support knowledgebase and see if there is any resolution to get his mail back. But you're certainely not responsible.
    "If you had a friend who was a tightrope walker, and you were walking down a sidewalk, and he fell, that would be completely unacceptable." -Mitch Hedberg

  4. #4
    Hi sarahsboy18,

    Thanks for the reply. Although this problem has been sorted for a while I figured I should post what transpired just in-case this thread is searched by someone looking for a resolution one-day (not that I am sure it will be - due to the nature of the problem).

    Anyway, here goes....

    Apparently with his version of Mac mail if you add two mail folders with the same username, they will both be deleted when you delete just one of them. This is what happened to my client. But that's just one of the problem he had.

    Another issue was that once he got his mail up and running again (he had typed in the wrong server details....) he was receiving the same message over and over. We are talking a frequency of thousands per minute here - big problem. I looked at our server logs and they were telling me that no mail was being downloaded by him at all. Yet he was telling me he was receiving thousands of copies every minute. At this stage I was ready to tell him to go elsewhere for his mail as I was adament it was not our server causing the problem. I had a brainwave and asked him to go to an area where he had no network connection (he is on wireless) and then try to check his mail. Should be able to cause he'd have no connection right? He did so and even though he had no connection his mail box kept expanding. It was then and only then that he finally conceded that it was his machine at fault. Not my server. What an enormous waste of my time.....

    So why was his machine doing this? He took it to Five (yes Five) different Mac Geniuses. All said that there was nothing wrong and that they could see any reason for it at all.

    Eventually he went to someone else who deleted all his preference files and emptied all the mail trash. Still have the problem. Once the machine was restarted it seemed to 'fix itself'. This other guy also couldn't explain what had happened, or why.

    I have a theory. I believe (given that this is not the first time it's happened to this machine) that he has an intermittment hard-disk fault (hence the original "mail box exclusively locked" message - for no apparent reason). I suspect that the area of the hard disk that is failing contained the termination headers for the message his mail kept receiving over and over. I know it's not very likely, but given that he's had these issues on only his laptop - there are four in his company all using my server - I suspect there is a hardware fault occuring.

    What a mission.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Itunes "folder" is locked
    By Rockin' Kat in forum OS X - Apps and Games
    Replies: 6
    Last Post: 09-01-2014, 07:56 AM
  2. "User" folder
    By pwf-iol in forum OS X - Operating System
    Replies: 11
    Last Post: 11-10-2010, 04:28 AM
  3. How do I access the "on my mac" folder in mail?
    By tltl in forum OS X - Apps and Games
    Replies: 2
    Last Post: 07-13-2009, 05:38 PM
  4. copy mail folder to new mac "file already exist"?
    By fletch33 in forum OS X - Operating System
    Replies: 2
    Last Post: 08-31-2008, 11:40 PM
  5. Mac "bands" in User Folder
    By BrockLanders in forum Apple Notebooks
    Replies: 2
    Last Post: 05-31-2008, 12:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts