Hi,
I am running app of a java application on Mac Mini, but it works if I double click on jar (from Show Package Content/Resources/Java)- and launch the application & run. but it does not work when I double click on the application itself.

The info.plist details is-


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist SYSTEM "file://localhost/System/Library/DTDs/PropertyList.dtd">
<plist version="0.9">
<dict>
<key>CFBundleName</key>
<string>Bucket Explorer</string>
<key>CFBundleIdentifier</key>
<string>com.simontuffs.onejar.Boot</string>
<key>CFBundleVersion</key>
<string>2010.04.00.01</string>
<key>CFBundleAllowMixedLocalizations</key>
<string>true</string>
<key>CFBundleExecutable</key>
<string>JavaApplicationStub</string>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundlePackageType</key>
<string>APPL</string>
<key>CFBundleShortVersionString</key>
<string>Version 2010.04.00.01</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleGetInfoString</key>
<string>Bucket Explorer, version 2010.04.00.01</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleIconFile</key>
<string>bucketexplorericns.icns</string>
<key>Java</key>
<dict>
<key>MainClass</key>
<string>com.simontuffs.onejar.Boot</string>
<key>JVMVersion</key>
<string>1.4+</string>
<key>WorkingDirectory</key>
<string>$JAVAROOT/</string>
<key>VMOptions</key>
<string>-Xmx512m</string>
<key>ClassPath</key>
<string>$JAVAROOT/BucketExplorer.jar</string>
<key>Properties</key>
<dict>
<key>com.apple.mrj.application.apple.menu.about.na me</key>
<string>Bucket Explorer</string>
<key>com.apple.mrj.application.live-resize</key>
<string>true</string>
<key>com.apple.macos.useScreenMenuBar</key>
<string>true</string>
<key>com.apple.hwaccel</key>
<string>false</string>
<key>com.apple.mrj.application.growbox.intrudes</key>
<string>false</string>
<key>javax.xml.parsers.DocumentBuilderFactory</key>
<string>org.apache.xerces.jaxp.DocumentBuilderFact oryImpl</string>
<key>javax.xml.parsers.SAXParserFactory</key>
<string>org.apache.xerces.jaxp.SAXParserFactoryImp l</string>
</dict>
</dict>
</dict>
</plist>


This application successfully launches on java version- 1.5.0_13 but if I run same application on java environment 1.6.0_17, and I click on app, it shows the application icon for a second then it disappears and nothing happen.


Thanks in advance,