Results 1 to 3 of 3
  1. #1
    Safari and Firefox both not working properly

    Member Since
    Sep 10, 2008
    Posts
    6
    Angry Safari and Firefox both not working properly
    I just did a clean install on leopard, it all went smoothly. then i downloaded firefox.

    but when i open either firefox or safari, when i click on a link instead of going thru to the page i clicked on which all browsers normally do, the page downloads as html, the downloads folder starts bouncing in the dock, grrrrrr, and i get a popup that says (name of file i downloaded) is a web application which was downloaded from the internet. are you sure you want safari or (firefox) to open it. then i have to click YES to get the page to open.

    i went to my preferences, everything seems to be in order, the box is checked the open "safe" files after downloading box is checked.

    is this some kind of permission problem? i can't figure out what to do, and obviously can't use my browsers. i'm totally stuck!!!

  2. #2
    Safari and Firefox both not working properly
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Fort Worth, Texas
    Posts
    45,284
    Specs:
    27" iMac i5, 3.2 GHz, iPad 3, iPhone 5c, iPhone 6+, 3 iPods, Yosemite
    That's a strange one. I would completely uninstall both Safari and Firefox.

    But before you do, download Safari from Apple and keep it in your downloads folder.

    Apple - Safari - Download After the download is completed, remove both Safari and Firefox. Just drag them to the Trash. Now, reinstall Safari. Do not download and install Firefox until you get Safari working right.

    Once Safari is working right, download and install Firefox.

    Regards.

  3. #3
    Safari and Firefox both not working properly
    kevindryer39's Avatar
    Member Since
    Aug 17, 2008
    Posts
    30
    Specs:
    Mac mini 1.66 GHz Intel Core Duo / 1GB 667 MHz DDR2 SDRAM / 80GB HD
    Not to discount your problem, but was this just one particular URL that was giving you the problem, or is it every URL you visit?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Command + Q is not working properly
    By ienakiko in forum OS X - Operating System
    Replies: 4
    Last Post: 05-15-2013, 01:12 PM
  2. My Safari software doesn't working properly
    By saif in forum Switcher Hangout
    Replies: 13
    Last Post: 10-18-2011, 01:15 AM
  3. earphone not working properly
    By zipperzipped in forum iOS and Apps
    Replies: 0
    Last Post: 06-21-2010, 03:26 AM
  4. Parallels not working Properly
    By jackfamous in forum Running Windows (or anything else) on your Mac
    Replies: 1
    Last Post: 02-02-2009, 10:24 AM
  5. Replies: 5
    Last Post: 05-18-2008, 06:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •