Results 1 to 4 of 4
  1. #1
    Cant find a solution to my Frozen Throne error!

    Member Since
    Aug 10, 2008
    Posts
    2
    Cant find a solution to my Frozen Throne error!
    Hi all i have ask dozens of people i know who little knows much about coding in games to i was hoping someone in the community might lend me a hand thanks!!

    I've installed both WC3, FT and the latest patch. Though WC3 works, FT doesnt! Hope you can help with the error report i got...

    Heres the error report:


    Date/Time: 2008-08-10 20:06:15.213 +0800
    OS Version: 10.4.11 (Build 8S2167)
    Report Version: 4

    Command: Warcraft III
    Path: /Applications/Warcraft III Folder/Warcraft III Folder/Warcraft III
    Parent: WindowServer [55]
    Rosetta: Yes

    Version: 1.0.7 (1.0.7, Copyright* 2002-2003 Blizzard Entertainment)

    PID: 254
    Thread: Unknown

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0x433b0058...


    ...Model: iMac5,1, BootROM IM51.0090.B09, 2 processors, Intel Core 2 Duo, 2.16 GHz, 1 GB
    Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 128 MB
    Memory Module: BANK 0/DIMM0, 512 MB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 512 MB, DDR2 SDRAM, 667 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x87), Broadcom BCM43xx 1.0 (4.170.46.9)
    Bluetooth: Version 1.9.5f4, 2 service, 1 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: WDC WD2500JS-40TGB0, 232.89 GB
    Parallel ATA Device: MAT****ADVD-R UJ-85J, 552.38 MB
    USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
    USB Device: Bluetooth USB Host Controller, Apple, Inc., Up to 12 Mb/sec, 500 mA
    USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA
    USB Device: Hub in Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 500 mA
    USB Device: Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 250 mA
    USB Device: Apple Optical USB Mouse, Primax Electronics, Up to 1.5 Mb/sec, 500 mA

  2. #2
    Cant find a solution to my Frozen Throne error!
    Lifeisabeach's Avatar
    Member Since
    Sep 30, 2007
    Location
    The Republic of Neptune
    Posts
    7,637
    That error report suggest you have v. 1.07 or Warcraft, which isn't the latest patch for Warcraft... not by a long shot. 1.07 wouldn't even be compatible with Intel Macs, iirc. Get the really really latest patches:

    http://www.versiontracker.com/dyn/moreinfo/macosx/15412

    http://www.versiontracker.com/dyn/moreinfo/macosx/20130

    Please verify and include the exact model/year of your Mac and OS X version number (available from "About This Mac", then "More Info" on the Apple menu).
    ------
    Links: Onyx | EasyFind | Apple Hardware Test | How to test your hard drive | The Safe Mac Adware Removal Guide | Uninstall MacKeeper
    ------
    Lifeisabeach - Mac-Forums Member of the Month June 2009, Feb 2012, and March 2013.

  3. #3
    Cant find a solution to my Frozen Throne error!

    Member Since
    Aug 10, 2008
    Posts
    1
    Frozen Throne Error
    Quote Originally Posted by w0bbles View Post
    Hi all i have ask dozens of people i know who little knows much about coding in games to i was hoping someone in the community might lend me a hand thanks!!

    I've installed both WC3, FT and the latest patch. Though WC3 works, FT doesnt! Hope you can help with the error report i got...

    Heres the error report:


    Date/Time: 2008-08-10 20:06:15.213 +0800
    OS Version: 10.4.11 (Build 8S2167)
    Report Version: 4

    Command: Warcraft III
    Path: /Applications/Warcraft III Folder/Warcraft III Folder/Warcraft III
    Parent: WindowServer [55]
    Rosetta: Yes

    Version: 1.0.7 (1.0.7, Copyright* 2002-2003 Blizzard Entertainment)

    PID: 254
    Thread: Unknown

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0x433b0058...


    ...Model: iMac5,1, BootROM IM51.0090.B09, 2 processors, Intel Core 2 Duo, 2.16 GHz, 1 GB
    Graphics: ATI Radeon X1600, ATY,RadeonX1600, PCIe, 128 MB
    Memory Module: BANK 0/DIMM0, 512 MB, DDR2 SDRAM, 667 MHz
    Memory Module: BANK 1/DIMM1, 512 MB, DDR2 SDRAM, 667 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x87), Broadcom BCM43xx 1.0 (4.170.46.9)
    Bluetooth: Version 1.9.5f4, 2 service, 1 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: WDC WD2500JS-40TGB0, 232.89 GB
    Parallel ATA Device: MAT****ADVD-R UJ-85J, 552.38 MB
    USB Device: Built-in iSight, Micron, Up to 480 Mb/sec, 500 mA
    USB Device: Bluetooth USB Host Controller, Apple, Inc., Up to 12 Mb/sec, 500 mA
    USB Device: IR Receiver, Apple Computer, Inc., Up to 12 Mb/sec, 500 mA
    USB Device: Hub in Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 500 mA
    USB Device: Apple Pro Keyboard, Mitsumi Electric, Up to 12 Mb/sec, 250 mA
    USB Device: Apple Optical USB Mouse, Primax Electronics, Up to 1.5 Mb/sec, 500 mA
    Hi w0bbles,

    I also have a problem with playing TFT on my Macbook, but I think it can come from the X3100 graphic chip and the drivers for mac...

    I think you made a mistake somewhere with your installation of RoC and TFT: the first is in version 1.0 or something like that and the second was released when War3 was in version 1.07 or something like that.

    That makes me think you have installed War3 RoC first (let's say in version 1.00), then installed TFT which updates RoC to the same version (that would be both 1.07) and then you installed the patch that put your RoC on last version (Intel-compatible) but ONLY RoC and not TFT.

    So the reason you can't launch TFT would be that you have not installed the complete patch (made for RoC+TFT) and only the patch to update RoC.

    To solve your problem you need to uninstall War3, because you must update both Roc and TFT together when you install them. So uninstall both, then install RoC (v1.00), then TFT (=>both at v1.07), and then install the good patch that will update BOTH RoC and TFT to last version.

    It whould work for you then, I think.

    As of my problem, I did not find any solution yet, and contact with Blizzard directly did not give me a solution (even if I have not yet tried the very last patch, currently being downloaded :]...) So I still have a black screen with only the mouse pointer and the version number when starting RoC or TFT v1.07, and I have an error when trying to install the last patch directly (saying the french patch is the wrong language even if it is the french version of the game, and that the CD cannot be read when trying the english patch, even if the CD player does not even start itself...)

    Anyway, I hope this will help you or people having the same problem than you .

    Good luck!

  4. #4
    Cant find a solution to my Frozen Throne error!

    Member Since
    Aug 10, 2008
    Posts
    2
    thanks guys!
    but i did everything suggested but this time round both ROC & TFT just wont open...keeps displaying the msg "application quit unexpectedly" so its getting worse now. i cant even open ROC like i used too...i dont suppose this is common?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warcraft 3 Frozen Throne Error Building Click error
    By Elayne in forum OS X - Apps and Games
    Replies: 0
    Last Post: 12-18-2011, 02:12 PM
  2. Error installing the 1.22a patch on warcraft 3 frozen throne
    By drummerdimitri in forum OS X - Apps and Games
    Replies: 3
    Last Post: 08-30-2008, 08:38 AM
  3. Warcraft 3 Frozen Throne not launching
    By Smidly in forum OS X - Apps and Games
    Replies: 2
    Last Post: 06-26-2008, 10:30 PM
  4. Frozen Throne sound broken!!
    By snikro in forum OS X - Apps and Games
    Replies: 0
    Last Post: 09-21-2005, 07:56 PM
  5. Can iBook run Frozen Throne well?
    By Bifgut in forum Apple Notebooks
    Replies: 8
    Last Post: 08-30-2005, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •