I got an email from Mike regarding the new Pith Helmet........

Sorry for the delay.

This should solve the problems with Safari 3.x.x installs and upgrades.

http://culater.net/dl/files/PithHelmet-2.8.3.tbz

-Mike