I posted this in the applications forum, but thought there might be more traffic and/or specific help here...

Ok. First off, I have a 1.42ghz G4 Mac Mini w/ 1gb RAM.

iDVD has always seemed to work fine in the past. No slowness issues, nothing. Now, whenever I open it up, it's EXTREMELY slow and unresponsive. The opening title/menu animations run stutteringly, and everything responds slowly when I click to do anything. I've deleted my old projects, which I thought may have caused some of the slowing issues.

I'm still a bit new to Macs, but I'm not exactly inept. Does hard drive space affect anything? I have approx 15gb of 80gb free right now on my internal hd.

iDVD is running so poorly now that it's almost unusable. I ditched Windows entirely to hopefully avoid problems like this.

I also have noticed that if I start a project, and then am on the 'themes' section - if I click on the button right next to the play button...the one with the 3 little screens/panes on it that allows you to see the structure or tree that your dvd follows, the theme animations run just fine. Then if I go back to the original screen that iDVD opens with, all seems fine... no slowness for the animations - HOWEVER, this doesn't do the trick every time. I'm pretty frustrated because I can't rely on something concretely to get it working right. Or, I'll go to say the Road Trip '04 animation and play it, and then go back to the original screen and then all's fine. It's kind of at random.

Can anyone help me to solve this problem or give me some insight as to what is going on?